TryChooser no longer deselects "All" nor does it update text field, when you uncheck options

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
STR:
 1. Visit http://trychooser.pub.build.mozilla.org/
 2. Uncheck some of the options under Platforms and Unit Test Suites
     (e.g. uncheck "linux" and "reftest")

EXPECTED RESULTS:
 "All" becomes unchecked and the TryChooser Syntax text box is updated

ACTUAL RESULTS:
 "All" remains checked, and TryChooser Syntax text box still has "-p all -u all"

This used to get EXPECTED RESULTS, but now it gets ACTUAL RESULTS, so I believe something changed on the site to break this.  (I don't think it's a browser bug, because I can reproduce with both a Nightly and a release build)

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120109 Firefox/12.0a1
(Reporter)

Updated

7 years ago
Summary: TryChooser no longer deselects "All" when you uncheck options → TryChooser no longer deselects "All" nor does it update text field, when you uncheck options
landed: http://hg.mozilla.org/build/tools/rev/1f58cd4de1be and updated trychooser site, this seems to work as expected now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.