Closed Bug 716797 Opened 10 years ago Closed 10 years ago

Crash on page load

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 717441

People

(Reporter: rnewman, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Attachments

(1 file)

Attached file adb log.
Samsung Galaxy S2, Android 2.3.4 (baseband I9100XXKI1, kernel 2.6.35.7-I9100…, build GINGERBREAD.XWKI4).

Build from current m-c. First time installed on this phone, IIRC.

Tapped on the first home screen favorite site. Crash soon after.

Log attached.

I'm guessing this is the culprit:

01-09 21:17:13.698 E/InputDispatcher( 2704): channel '40b79080 org.mozilla.fennec_rnewman/org.mozilla.fennec_rnewman.App (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
01-09 21:17:13.698 E/InputDispatcher( 2704): channel '40b79080 org.mozilla.fennec_rnewman/org.mozilla.fennec_rnewman.App (server)' ~ Channel is unrecoverably broken and will be disposed!
01-09 21:17:13.698 I/DEBUG   ( 2582): debuggerd committing suicide to free the zombie!
01-09 21:17:13.698 I/ActivityManager( 2704): Process org.mozilla.fennec_rnewman (pid 4936) has died.
01-09 21:17:13.698 I/WindowManager( 2704): WIN DEATH: Window{40b73ba0 SurfaceView paused=false}
01-09 21:17:13.703 D/Zygote  ( 2586): Process 4936 exited cleanly (11)
01-09 21:17:13.703 I/DEBUG   ( 5040): debuggerd: Sep 14 2011 20:33:41


Assorted other interesting log bits:

01-09 21:17:13.113 I/Gecko   ( 4936): ###!!! ASSERTION: nsAndroidHistory not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file /Users/rnewman/moz/hg/mozilla-central/toolkit/components/places/nsAndroidHistory

01-09 21:17:13.148 E/BulkCursor( 4936): Unable to requery because the remote process exception Only the original thread that created a view hierarchy can touch its views.

01-09 21:17:13.438 I/Gecko   ( 4936): ###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr', file ../../dist/include/nsCOMPtr.h, line 532

01-09 21:17:13.563 I/Gecko   ( 4936): ###!!! ASSERTION: reacquiring already acquired resource: 'mDDEntry->mAcquisitionContext == CallStack::kNone', file /Users/rnewman/moz/hg/mozilla-central/objdir-droid/xpcom/build/BlockingResourceBase.cpp, line 174
Severity: normal → critical
Whiteboard: [native-crash]
This looks like a debug build and it sounds like bug 717441. Could you try this with --disable-optimize removed from your mozconfig at some point? Or try an opt build?
Richard - The fix for the busted debug builds has landed on m-c. Can you retest?
Opt build has been happily working since that was suggested on IRC. I'll try a debug build of tip today.
Closing based on guess that this was a debug build issue, fixed in bug 717441. If I'm wrong, re-open.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717441
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.