Last Comment Bug 716842 - l10n repacks need the makefile in mobile/locales
: l10n repacks need the makefile in mobile/locales
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Axel Hecht [pto-Aug-30][:Pike]
:
Mentors:
Depends on: 708015
Blocks: 697384 698425
  Show dependency treegraph
 
Reported: 2012-01-10 02:07 PST by Axel Hecht [pto-Aug-30][:Pike]
Modified: 2012-01-31 06:05 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
generate mobile/locales/Makefile (1.71 KB, patch)
2012-01-10 03:31 PST, Axel Hecht [pto-Aug-30][:Pike]
aki: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Axel Hecht [pto-Aug-30][:Pike] 2012-01-10 02:07:23 PST
Missed this when doing bug 708015, the Makefile in mobile/locales is currently only done when building from mobile/android or /xul, per DIRS.

It's not there when you start your journey in mobile/android/locales.

Do what branding does is the way to go.
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2012-01-10 03:31:41 PST
Created attachment 587270 [details] [diff] [review]
generate mobile/locales/Makefile

This makes sure that the mobile/locales/Makefile is created, by both configure and the Makefile logic in mobile/*/locales/Makefile.in.

Trivial patch, also pushed to try at https://tbpl.mozilla.org/?tree=Try&rev=a69a530db418 with a minimal build set.
Comment 2 Aki Sasaki [:aki] 2012-01-10 11:09:31 PST
Hm, I'm getting

 extracting: omni.ja                 
  inflating: classes.dex             
mv: cannot stat `lib/armeabi-v7a/libmozglue.so': No such file or directory
make: *** [/builds/slave/m-cen-andrd-l10n-1/mozilla-central/obj-l10n/mobile/android/locales/../../../dist/l10n-stage/fennec] Error 1
command: END (0.39s elapsed)

Traceback (most recent call last):
  File "/builds/slave/m-cen-andrd-l10n-1/scripts/scripts/l10n/nightly-mobile-repacks.py", line 191, in <module>
    options.platform, stage_platform, mobileDirName, en_us_binary_url)
  File "/builds/slave/m-cen-andrd-l10n-1/scripts/scripts/l10n/nightly-mobile-repacks.py", line 51, in createRepacks
    buildInfo = downloadNightlyBuild(localeSrcDir, env)
  File "/builds/slave/m-cen-andrd-l10n-1/scripts/scripts/l10n/../../lib/python/build/download.py", line 8, in downloadNightlyBuild
    run_cmd(["make", "unpack"], cwd=localeSrcDir, env=env)
  File "/builds/slave/m-cen-andrd-l10n-1/scripts/scripts/l10n/../../lib/python/util/commands.py", line 42, in run_cmd
    return subprocess.check_call(cmd, **kwargs)
  File "/tools/python-2.5.1/lib/python2.5/subprocess.py", line 461, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['make', 'unpack']' returned non-zero exit status 2

I currently suspect http://hg.mozilla.org/mozilla-central/rev/c899dde43144 .
Comment 3 Aki Sasaki [:aki] 2012-01-10 11:20:12 PST
[11:11]	<glandium>	aki: it suggests you're using a packager.mk that is newer than the build you're using it on

Building a new nightly to test on.
Comment 4 Axel Hecht [pto-Aug-30][:Pike] 2012-01-10 11:22:00 PST
Yeah, http://hg.mozilla.org/mozilla-central/diff/cf890c9c3e4c/toolkit/mozapps/installer/packager.mk looks OK as long as your build and your tree are on the same side of the tree.
Comment 5 Aki Sasaki [:aki] 2012-01-10 12:29:07 PST
Comment on attachment 587270 [details] [diff] [review]
generate mobile/locales/Makefile

I have android l10n jobs going green now (with this patch), thanks!
There are some that are broken, but those look like locales that need updating (

    raise RuntimeError('File "%s" not found in %s' % (src, ', '.join(src_base)))
RuntimeError: File "wikipedia-he.xml" not found in /builds/slave/m-cen-andrd-l10n-3/mozilla-central/mobile/locales/en-US/searchplugins, /builds/slave/m-cen-andrd-l10n-3/l10n-central/he/mobile/searchplugins, /builds/slave/m-cen-andrd-l10n-3/mozilla-central/obj-l10n/mobile/locales, /builds/slave/m-cen-andrd-l10n-3/mozilla-central/obj-l10n/mobile/locales
make[3]: *** [searchplugins] Error 1

)

Shipit!
Comment 6 Axel Hecht [pto-Aug-30][:Pike] 2012-01-10 12:57:23 PST
https://hg.mozilla.org/mozilla-central/rev/fee66b45f486, marking FIXED.
Comment 7 Axel Hecht [pto-Aug-30][:Pike] 2012-01-10 16:12:15 PST
Comment on attachment 587270 [details] [diff] [review]
generate mobile/locales/Makefile

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: no fennec l10n builds for 11
Testing completed (on m-c, etc.): it built, aki's doing the release integration of this and gave the r+
Risk to taking this patch (and alternatives if risky): no risk really, just creating more makefiles early in the build run
Comment 8 Alex Keybl [:akeybl] 2012-01-10 16:15:24 PST
Comment on attachment 587270 [details] [diff] [review]
generate mobile/locales/Makefile

[Triage Comment]
Approved for Aurora to get fennec l10n builds.
Comment 9 Axel Hecht [pto-Aug-30][:Pike] 2012-01-11 14:27:39 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/c0633c711e80, fixed for 11.
Comment 10 Cristian Nicolae (:xti) 2012-01-31 06:05:19 PST
Verified fixed on:

Mozilla/5.0 (Android;Linux armv7l;rv:11.0a2)Gecko/20120130
Firefox/11.0a2 Fennec/11.0a2
Device: Samsung Galaxy S
OS: Android 2.2

Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120130
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.