Last Comment Bug 716853 - IonMonkey: Mark the invalidator thunk
: IonMonkey: Mark the invalidator thunk
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
:
Mentors:
Depends on:
Blocks: IonMonkey
  Show dependency treegraph
 
Reported: 2012-01-10 04:57 PST by Jan de Mooij [:jandem]
Modified: 2012-01-10 14:05 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.23 KB, patch)
2012-01-10 05:01 PST, Jan de Mooij [:jandem]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-01-10 04:57:36 PST

    
Comment 1 Jan de Mooij [:jandem] 2012-01-10 05:01:38 PST
Created attachment 587276 [details] [diff] [review]
Patch

Fixes the SS harness. It was crashing because the gc() after every test freed the invalidator thunk, and later tests would bailout and return to garbage code.
Comment 2 Jan de Mooij [:jandem] 2012-01-10 05:15:26 PST
http://hg.mozilla.org/projects/ionmonkey/rev/6a3adb008b1e

Note You need to log in before you can comment on or make changes to this bug.