fennec_12.0~a1_armel.deb instant-crashes on launch

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Max, @maxart, Assigned: romaxa)

Tracking

({crash})

Firefox 12
ARM
MeeGo
crash

Details

(Whiteboard: [mobile-crash])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20120109 Firefox/12.0a1
Build ID: 20120109085652

Steps to reproduce:

I downloaded and installed the fennec_12.0~a1 build on my Nokia N9 (PR1.1) from: http://romaxa.bolshe.net/fennec/mozilla-central/fennec_12.0~a1_armel.deb


Actual results:

"fennec_12.0~a1_armel" near instant-crashes (everytime) on launch  (build: romaxa.bolshe.net/fennec/mozilla-central/fennec_12.0~a1_armel.deb ) on the Nokia N9 (MeeGo/Harmattan - PR1.1).
Fennec opens, and crashes before I can interact with it.


Expected results:

I would have expected it to work just as well as "fennec_11.0~a2_armel.deb".
(Reporter)

Comment 1

7 years ago
What can I provide to help pin down the problem?
(Reporter)

Updated

7 years ago
OS: Mac OS X → MeeGo
Hardware: x86 → ARM

Comment 2

7 years ago
Nighlty builds must be downloaded from http://nightly.mozilla.org/.
Anyway, Fennec doesn't support Meego yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → General
Product: Fennec Native → Fennec
Resolution: --- → INVALID

Comment 3

7 years ago
Scoobidiver: Please don't close bugs related to Meego/Harmattan builds of Firefox. They are community contributed builds, not Mozilla builds, therefore you can't download them from mozilla. However reporting related bugs here is in order, since these builds use Mozilla source.

Updated

7 years ago
Severity: normal → critical
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: crash
Resolution: INVALID → ---

Updated

7 years ago
Whiteboard: [mobile-crash]

Comment 4

7 years ago
CCing romaxa, who is doing those builds, actually.
(Assignee)

Comment 5

7 years ago
Ok, I'll check it.
Assignee: nobody → romaxa
(Assignee)

Comment 6

7 years ago
Just tested latest build and it seems to work fine for me, could you try latest one, also provide info from http://romaxa.bolshe.net/fennec/mozilla-central/build_info.txt, and would be nice to get coredump or richcore file
(Reporter)

Comment 7

7 years ago
@romaxa Sure, will do (hopefully today). 

How do I delete my Fennec profile on the N9? (it might have been because my 11.0 profile was still there when I tried to install 12.0?)
(Reporter)

Comment 8

7 years ago
@romaxa I just tried http://romaxa.bolshe.net/fennec/mozilla-central/fennec_12.0~a1_armel.deb (available Mozilla Central build at 9AM, GMT+7), and it is working fine on my N9/PR1.1 - no crashes whatsoever.

So I guess it's all good now.

2012/01/2012-01-10-14-mozilla-central
Revision: changeset:   84107:1962ca549264

Thanks again for the quick replies!
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.