Browser very slow (almost freezes)

VERIFIED DUPLICATE of bug 64188

Status

()

Core
ImageLib
--
critical
VERIFIED DUPLICATE of bug 64188
17 years ago
17 years ago

People

(Reporter: Gunther Strube, Assigned: pnunn)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010311
BuildID:    2001011120

It's as if Mozilla has a very hard time rendering Html stuff (takes a long
time), before control is returned to keyboard/mouse.

I think that the problem were introduced in 0.7, but are not sure.

jedit.sourceforge.net works fine in Netscape 4.x, IE4.x / 5.x, Opera 5.x

Reproducible: Always
Steps to Reproduce:
just go to jedit.sourceforge.net
worksforme, build 2001-03-12-05 on Linux.  No undue cpu usage or freezing observed.

Comment 2

17 years ago
I can see this problem on Win98, build 2001031120 as well.  And it makes the
whole system slow.  I thought at first it was the same problem as the PSM bug,
but PSM isn't being loaded at all.

Comment 3

17 years ago
I believe this is due to the background image (background.png).

File: background.png (154 bytes)
  chunk IHDR at offset 0x0000c, length 13
    1 x 3 image, 32-bit RGB+alpha, non-interlaced
  chunk gAMA at offset 0x00025, length 4: 0.45455
  chunk bKGD at offset 0x00035, length 6: red = 255 green = 255 blue = 255
  chunk pHYs at offset 0x00047, length 9: 2833x2833 pixels/meter (72 dpi)
  chunk tIME at offset 0x0005c, length 7: 22 Dec 2000 05:54:43 GMT
  chunk IDAT at offset 0x0006f, length 23
    zlib:  deflated, 32K window, default compression
  chunk IEND at offset 0x00092, length 0
No errors detected in background.png (-1183.3% compression).

It's got a fully opaque alpha channel. If this is, indeed, the problem then it's
a known bug (but I can't find it right now).

Comment 5

17 years ago
updating component
Assignee: asa → pnunn
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 64188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.