crash [@ js::detail::HashTable<js::Shape* const, js::HashSet<js::Shape*, js::ShapeHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::lookup ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: Christian Riechers, Unassigned)

Tracking

({crash})

9 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rare][need steps to reproduce], crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120104111456



Actual results:

Crash Report [@ js::detail::HashTable<js::Shape* const, js::HashSet<js::Shape*, js::ShapeHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::lookup ]
ID: 7059c5e5-19a1-4579-bae9-8a92d2120109
https://crash-stats.mozilla.com/report/index/bp-7059c5e5-19a1-4579-bae9-8a92d2120109

An infrequent crash for Thunderbird.
OS is Linux OpenSuSE 11.4.
(Reporter)

Updated

7 years ago
Severity: normal → critical
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Crash Signature: [@ js::detail::HashTable<js::Shape* const, js::HashSet<js::Shape*, js::ShapeHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::lookup ]
Component: General → JavaScript Engine
Ever confirmed: true
Product: Thunderbird → Core
QA Contact: general → general
Version: 9 → 9 Branch

Comment 1

6 years ago
Christian, based on looking at bug 645881 which afaict is the windows equivalent crash sig (reported for firefox, I doubt there's much hope for this crash report unless you have steps to reproduce. Do you have steps for this (or bug 716336)?

also there is only one other TB unix crash in the past month - so this is rare.  windows crashes are more frequient, but the two I examined, bp-b092151c-31dd-488f-ae75-5f66c2120111 for example, don't have the same stack as your crash. In other words, you have a pretty unique, perhaps even random crash.

I'd further guess that your other crash, bug 716336, may be related. 

your crash bp-7059c5e5-19a1-4579-bae9-8a92d2120109
0	libxul.so	js::detail::HashTable<js::Shape* const, js::HashSet<js::Shape*, js::ShapeHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::lookup	js/src/jspropertytree.cpp:205
1	libxul.so	js::HashSet<js::Shape*, js::ShapeHasher, js::SystemAllocPolicy>::remove	js/src/jshashtable.h:666
2	libxul.so	js::Shape::finalize	js/src/jspropertytree.cpp:148
3	libxul.so	js::gc::Arena::finalize<js::Shape>	js/src/jsgc.cpp:301
4	libxul.so	js::gc::FinalizeTypedArenas<js::Shape>	js/src/jsgc.cpp:348
5	libxul.so	js::gc::FinalizeArenas	js/src/jsgc.cpp:395
6	libxul.so	GCCycle	js/src/jsgc.cpp:1288
7	libxul.so	js_GC	js/src/jsgc.cpp:2735
8	libxul.so	JS_CompartmentGC	js/src/jsapi.cpp:2616
9	libxul.so	JS_GC	js/src/jsapi.cpp:2623
10	libxul.so	nsXPConnect::Collect	js/src/xpconnect/src/nsXPConnect.cpp:415
11		@0x1f	
12	libxul.so	nsXPConnect::GarbageCollect	js/src/xpconnect/src/nsXPConnect.cpp:423
13	libxul.so	nsJSContext::GarbageCollectNow	dom/base/nsJSEnvironment.cpp:3189
14	libxul.so	nsTimerImpl::Fire	xpcom/threads/nsTimerImpl.cpp:424
15	libxul.so	nsTimerEvent::Run	xpcom/threads/nsTimerImpl.cpp:520
Keywords: crash
Whiteboard: [rare][need steps to reproduce]
(Reporter)

Comment 2

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> Christian, based on looking at bug 645881 which afaict is the windows
> equivalent crash sig (reported for firefox, I doubt there's much hope for
> this crash report unless you have steps to reproduce. Do you have steps for
> this (or bug 716336)?

Unfortunately not. These crashes happened just out of the blue without doing anything.

> also there is only one other TB unix crash in the past month - so this is
> rare.  windows crashes are more frequient, but the two I examined,
> bp-b092151c-31dd-488f-ae75-5f66c2120111 for example, don't have the same
> stack as your crash. In other words, you have a pretty unique, perhaps even
> random crash.
> 
> I'd further guess that your other crash, bug 716336, may be related. 
> 

What I can tell is that I do see TB crashes about once a day since the upgrade to TB9.0.1 - see also bug 654073, bug 658479, and bug 564566.
I do not know if these are related in any way, some are even marked as fixed. But I'd at least suspect there is a connection between all these crashes.
I'll check whether TB10 b3 will behave any better. All those crashes where seen using Linux. 
There were no crashes for me using TB9.0.1 or 10 beta using Windows.
(Reporter)

Comment 3

6 years ago
TB 10b3 was running stable. TB 10b4 crashed within 24 hrs after installation. See bug 719887.
(Reporter)

Comment 5

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> Christian, have your crashes reduced in newer releases?

Yes, I haven't seen a crash anymore since quite a while, and certainly none with TB 17.
Also the bug was raised while running OpenSuse 11.4. I'm on 12.2 by now, which may also play a role.
Flags: needinfo?(chriechers)

Comment 6

6 years ago
WFM per reporter
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.