[traceback] AttributeError while searching

RESOLVED DUPLICATE of bug 721184

Status

support.mozilla.org
Search
RESOLVED DUPLICATE of bug 721184
6 years ago
6 years ago

People

(Reporter: jsocol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Using recent production data and searching for "private browsing" I got the following error. I suspect the issue is that we indexed a document without a current_revision, which is legal, and it ended up in the result set, which it shouldn't. (Note that this is an AttributeError, so current_revision is None, not a DoesNotExist, which came up a couple times with this prod data during indexing.)

Environment:


Request Method: GET
Request URL: https://support-local.allizom.org/en-US/search?e=es&q=private+browsing

Django Version: 1.3
Python Version: 2.6.4


Traceback:
File "/var/www/kitsune/vendor/src/django/django/core/handlers/base.py" in get_response
  111.                         response = callback(request, *callback_args, **callback_kwargs)
File "/var/www/kitsune/vendor/src/django-mobility/mobility/decorators.py" in wrapper
  23.             return f(request, *args, **kw)
File "/var/www/kitsune/apps/search/views.py" in search
  334.                     summary = doc.current_revision.summary

Exception Type: AttributeError at /search
Exception Value: 'NoneType' object has no attribute 'summary'
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721184
You need to log in before you can comment on or make changes to this bug.