If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When using "use system proxy settings" some websites redirect indefinitely

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
major
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Katy Levinson, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When attempting to load certain pages (for example, www.tumblr.com) an error appears.

---

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

If a user goes into preferences and sets the proxy to "no proxy" the problem goes away and the pages will load.

---

If the setting is then reverted from "No proxy" to "Use System Proxy Settings" and the page is refreshed, the site will still load. However, any URL post-login will result in the error pasted above. Additionally, if the original URL is typed in again instead of hitting refresh, the error will come back.

Operating system is a clean install of OSX Lion with no alterations to the proxy configuration.

Thanks guys
(Reporter)

Comment 1

6 years ago
(In reply to Katy Levinson from comment #0)
> When attempting to load certain pages (for example, www.tumblr.com) an error
> appears.
> 
> ---
> 
> The page isn't redirecting properly
> 
> Firefox has detected that the server is redirecting the request for this
> address in a way that will never complete.
> 
> This problem can sometimes be caused by disabling or refusing to accept
> cookies.
> 
> If a user goes into preferences and sets the proxy to "no proxy" the problem
> goes away and the pages will load.
> 
> ---
> 
> If the setting is then reverted from "No proxy" to "Use System Proxy
> Settings" and the page is refreshed, the site will still load. 

Apologies, I forgot to mention that the browser must be restarted for these changes to take effect. When reverting the changes to verify that this solved the problem, the browser does not need to be restarted.

> However, any
> URL post-login will result in the error pasted above. Additionally, if the
> original URL is typed in again instead of hitting refresh, the error will
> come back.
> 
> Operating system is a clean install of OSX Lion with no alterations to the
> proxy configuration.
> 
> Thanks guys
(Reporter)

Comment 2

6 years ago
Problem verified to be Firefox OSX specific: Windows 7 and Ubunutu 11.10 both running 9.0.1 do not have this problem.
Katy, is this issue still happening for you? I was unable to replicate it with OSX 10.8.3 and Firefox 20.
Flags: needinfo?(katylevinson)
Katy, is this still being an issue. Unable to reproduce the issue with OSX 10.8.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(katylevinson)
You need to log in before you can comment on or make changes to this bug.