Add an "options" property to package.json for custom options.xul files

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
I'm getting tired of adding this functionality to the SDK myself on every new release, so I figured I'd share my work with the community.

While the simple-prefs module now provides an avenue for the inclusion of inline options, it's far from complete, and there'll always be cases where it's advantageous to code options.xul by hand; therefore, I propose an extra packages.json property, "options", which allows one to specify a custom options.xul file. If "options.xul" is found in the add-on's folder, it should be included in the build automatically, just as "icon" and "icon64" currently are.

Attached is a two-part patch for 1.4 final which accomplishes these goals. It was created with "diff". I don't have time to learn git, but it's a simple patch, so hopefully what's here will be sufficient for someone to run with it.
(Reporter)

Comment 1

7 years ago
Created attachment 587494 [details] [diff] [review]
Patch for python-lib/cuddlefish/packaging.py
(Reporter)

Comment 2

7 years ago
Created attachment 587495 [details] [diff] [review]
Patch for python-lib/cuddlefish/xpi.py
(Reporter)

Updated

7 years ago
Summary: Add an "options" property to packages.json for custom options.xul files → Add an "options" property to package.json for custom options.xul files
Brian, Alex, what do you guys think about these changes?
What is missing from simple-prefs that you'd like to do?
Whiteboard: [triage:followup]
(Reporter)

Comment 5

7 years ago
Menulists. I also need to specify ids for my menulists so I can programmatically add new items at runtime, and I'm unable to use simple-prefs at all until bug 717062 is resolved.
Could you open a new bug specifically for adding menulists and the other things you want into simple-prefs?

We're wontfixing this because we want to make sure that whatever the SDK is using can survive Firefox changing the way it deals with options.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: [triage:followup]
You need to log in before you can comment on or make changes to this bug.