No Classic Setup Error thrown on screen

RESOLVED DUPLICATE of bug 705767

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 705767
6 years ago
a month ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 587516 [details]
screenshot of successful logon

If you enter in wrong credentials on classic sync setup, there is no indication that you've made mistakes.   Logging seems correct though.

Screenshot and Logcat attached.  

Repro:
1) install rnewman's 1-9-2012 sync build
2) Open Settings > accounts > add Account > Firefox Sync
3) click i dont have device
4) Enter in incorrect data in the 3 text fields
5) click connect, and verify the phone tells the user Setup is Complete.

Expectd:
- setup should fail, since credentials are wrong

Actual:
- setup complete on the screen
(Reporter)

Comment 1

6 years ago
Created attachment 587517 [details]
logcat expected failure
Needs verification of credentials during setup, of course.
Depends on: 705767
(Reporter)

Comment 3

6 years ago
cc'ing ux team
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705767
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

a month ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.