Closed Bug 717159 Opened 8 years ago Closed 8 years ago

smoothing svg

Categories

(Firefox :: Untriaged, defect)

9 Branch
All
Linux
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: mail, Unassigned)

Details

Attachments

(1 file)

14.53 KB, text/plain
Details
Attached file pixel.html
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.15 (KHTML, like Gecko) Ubuntu/10.10 Chromium/18.0.996.0 Chrome/18.0.996.0 Safari/535.15

Steps to reproduce:

open html page with svg
test page for bug: http://alltiptop.me/bugs/pixel.html


Actual results:

blurred boundaries svg (icon, logo, image etc; but not text) with different window size, screenshot: http://wstaw.org/m/2012/01/11/plasma-desktopbz4977.jpg


Expected results:

always clear-cut line and snap to the pixel grid in accordance with atributes in svg, if the dimensions are in pixels
OS: Linux → All
Hardware: x86_64 → All
OS: All → Linux
If you don't want antialiasing then turn it off using shape-rendering="crispEdges" in the content. Doesn't that work for you?
(In reply to Robert Longson from comment #1)
> If you don't want antialiasing then turn it off using
> shape-rendering="crispEdges" in the content. Doesn't that work for you?

Thanks, but new bug - firefox cut 1 px with top and left.
(In reply to Robert Longson from comment #1)
> If you don't want antialiasing then turn it off using
> shape-rendering="crispEdges" in the content. Doesn't that work for you?

http://i.imgur.com/j8z4V.png
You need to align the lines correctly per: http://cairographics.org/FAQ/#sharp_lines
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
(In reply to Robert Longson from comment #4)
> You need to align the lines correctly per:
> http://cairographics.org/FAQ/#sharp_lines

Neither option is acceptable, since the smoothing is lost.
blurred, normal and with shape-rendering="crispEdges" svg icons:
http://i.imgur.com/D3EYq.png
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
You'll have to target the smoothing at the bits you need. You can smooth the paths wou want by making just them crispEdges and not others.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.