If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"click here" on download.html redirect you to a webpage

RESOLVED WORKSFORME

Status

www.mozilla.org
General
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
had problems downloading firefox 9.0.1 this morning due to unreleated issues and landed on http://www.mozilla.org/en-US/products/download.html?product=firefox-9.0.1&os=win&lang=en-US and there is a text : Start the process by clicking Run. Your download should begin automatically. If not, click here. It could take a few minutes, but it’s worth the wait.

The "click here" does not start (as you would assume on other pages) a download, it redirects you to http://www.mozilla.org/en-US/products/ and thats basically where the whole thing started, so maybe we should redirect instead to a webpage to the real binary/installer download.
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
This is no longer reproducible.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.