Last Comment Bug 717193 - IonMonkey: spectral-norm correctness bug with LSRA
: IonMonkey: spectral-norm correctness bug with LSRA
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-11 02:33 PST by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2012-01-11 14:39 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (9.90 KB, patch)
2012-01-11 11:20 PST, Jan de Mooij [:jandem] (PTO until July 31)
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2012-01-11 02:33:20 PST
Seems to be a regression from bug 715737. I'm quite certain this was broken before though, it was just hidden by the order in which we inserted movegroups.
Comment 1 Jan de Mooij [:jandem] (PTO until July 31) 2012-01-11 11:20:42 PST
Created attachment 587759 [details] [diff] [review]
Patch

The fix itself is small, but this also removes the outputMoves movegroup, since we don't really need it if we give blocks an exit movegroup. Every VirtualRegister now has only 2 movegroups, before and after.
Comment 2 Jan de Mooij [:jandem] (PTO until July 31) 2012-01-11 14:39:34 PST
http://hg.mozilla.org/projects/ionmonkey/rev/d04701f99b81

Note You need to log in before you can comment on or make changes to this bug.