Last Comment Bug 717198 - Remove tag observers
: Remove tag observers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Henri Sivonen (:hsivonen)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 03:20 PST by Henri Sivonen (:hsivonen)
Modified: 2012-01-12 08:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove the dead code (19.40 KB, patch)
2012-01-11 03:23 PST, Henri Sivonen (:hsivonen)
mrbkap: review+
Details | Diff | Review

Description Henri Sivonen (:hsivonen) 2012-01-11 03:20:22 PST
Tag observers have been unused since Firefox 4. Let's get rid of the code.
Comment 1 Henri Sivonen (:hsivonen) 2012-01-11 03:23:03 PST
Created attachment 587645 [details] [diff] [review]
Remove the dead code

Another patch that just removes old code.
Comment 2 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-11 04:47:59 PST
Comment on attachment 587645 [details] [diff] [review]
Remove the dead code

Review of attachment 587645 [details] [diff] [review]:
-----------------------------------------------------------------

::: parser/htmlparser/public/nsIHTMLContentSink.h
@@ -221,5 @@
> -   * the tag
> -   *
> -   * @param aErrorResult the error code
> -   */
> -  NS_IMETHOD NotifyTagObservers(nsIParserNode* aNode) = 0;

Need to bump the IID here.
Comment 3 Henri Sivonen (:hsivonen) 2012-01-11 07:51:39 PST
Thanks. Landed with revised IID.
https://hg.mozilla.org/integration/mozilla-inbound/rev/418f713f7092
Comment 4 Henri Sivonen (:hsivonen) 2012-01-12 00:53:19 PST
No need for add-on compat keywords, because this stuff hasn't actually been used since Firefox 4.
Comment 5 Matt Brubeck (:mbrubeck) 2012-01-12 08:33:42 PST
https://hg.mozilla.org/mozilla-central/rev/418f713f7092

Note You need to log in before you can comment on or make changes to this bug.