Relative URLs incompatible with Netscape and RFC 1808

VERIFIED DUPLICATE of bug 34648

Status

VERIFIED DUPLICATE of bug 34648
18 years ago
14 years ago

People

(Reporter: psfales, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
According to RFC 1808, it is possible for an page to contain a URL
reference which is relative to the current page by leaving off the net_loc.
That is, if the documents URL is http://host.foo.com/index.html, then
within that document, links to http:/host.foo.com/page.html and http:/page.html
should be equivalent.  This works with netscape 4.7*, but not with mozilla 0.8.
I've created an example at http://www.workspot.net/~psfales
(Reporter)

Comment 1

18 years ago
This problem shows up on both the Linux and Solaris versions of Mozilla 0.8.  It
may be related to bug 65650, but that bug seems to be related to URLS within
tables and this problem seems more general than that.

Comment 2

18 years ago
You mean this part of RFC 1808?

"  Finally, some older parsers allow the scheme name to be present in a
   relative URL if it is the same as the base URL scheme.  This is
   considered to be a loophole in prior specifications of partial URLs
   [1] and should be avoided by future parsers.

      http:g        = <URL:http:g>
      http:         = <URL:http:>
"

This is a dupe of some bug, in which we already decided not to add backward 
compatibility support for this.

Let me go find that dupe.

Comment 3

18 years ago
There we go. Dupe of bug 34648.

If you disagree, please reopen that one.

*** This bug has been marked as a duplicate of 34648 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy, although i think we might have parallel dupes lying around.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.