Last Comment Bug 717278 - Vector should have const and non-const begin()
: Vector should have const and non-const begin()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: mozilla12
Assigned To: Jason Orendorff [:jorendorff]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 09:53 PST by Jason Orendorff [:jorendorff]
Modified: 2012-01-21 06:55 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.24 KB, patch)
2012-01-11 10:23 PST, Jason Orendorff [:jorendorff]
luke: review+
Details | Diff | Splinter Review

Description Jason Orendorff [:jorendorff] 2012-01-11 09:53:31 PST
Vector has both const and non-const end() methods but only a const begin() method, and it returns a pointer-to-non-const T, which seems wrong to me.
Comment 1 Luke Wagner [:luke] 2012-01-11 09:55:27 PST
Indeed, Vector used to have this right; it looks like it regressed in http://hg.mozilla.org/mozilla-central/rev/b60ac564e39d#l1.253.
Comment 2 Jason Orendorff [:jorendorff] 2012-01-11 10:23:26 PST
Created attachment 587745 [details] [diff] [review]
v1
Comment 3 Ed Morley [:emorley] 2012-01-21 06:55:23 PST
https://hg.mozilla.org/mozilla-central/rev/11ba93db719a

Note You need to log in before you can comment on or make changes to this bug.