If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Azure SVG gradient rendering is broken

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: Marek Raida, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 587801 [details]
banner2.svg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120111 Firefox/12.0a1
Build ID: 20120111031049

Steps to reproduce:

Displaying SVG document with gradients on text and circle with gfx.content.azure.enabled=true using latest nightly build...
Attached reduced case is taken from http://svg.kvalitne.cz/banner2/banner2.svg


Actual results:

Gradient on circle is shifted somehow and text fill is not rendered at all


Expected results:

It should look rendered like with azure rendering disabled...
I could not reproduce this on the 1/11 nightly using azure backed by d2d with some intel graphics chip (I can get the exact model #/driver version if it's important).
Marek, could you post a screenshot of the broken rendering?
(Reporter)

Comment 3

6 years ago
Created attachment 587954 [details]
Broken rendering example

Sure, here it is and my SYS details are:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120111 Firefox/12.0a1
NVIDIA GeForce GT 240M
Driver Version 8.17.12.8562
Direct2D Enabled true 
DirectWrite Enabled true (6.1.7601.17563)
ClearType Parameters Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 
WebGL Renderer NVIDIA Corporation -- GeForce GT 240M/PCI/SSE2 -- 3.3.0
GPU Accelerated Windows 1/1 Direct3D 10
AzureBackend direct2d

and is I change gfx.content.azure.enabled=true/false on the fly, without restart, only switching tabs,it is rendered well/badly based on settings

So text is not visible at all, gradient on circle is broken...
(In reply to Marek Raida from comment #3)
> Created attachment 587954 [details]
> Broken rendering example
> 
> Sure, here it is and my SYS details are:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120111 Firefox/12.0a1
> NVIDIA GeForce GT 240M
> Driver Version 8.17.12.8562
> Direct2D Enabled true 
> DirectWrite Enabled true (6.1.7601.17563)
> ClearType Parameters Gamma: 2200 Pixel Structure: RGB ClearType Level: 100
> Enhanced Contrast: 50 
> WebGL Renderer NVIDIA Corporation -- GeForce GT 240M/PCI/SSE2 -- 3.3.0
> GPU Accelerated Windows 1/1 Direct3D 10
> AzureBackend direct2d
> 
> and is I change gfx.content.azure.enabled=true/false on the fly, without
> restart, only switching tabs,it is rendered well/badly based on settings
> 
> So text is not visible at all, gradient on circle is broken...

Switching on the fly isn't 'really' expected to work well, it's just usable for some debug purposes if you know what to expect. Thanks for the screenshot though!
Marek, what happens if you turn on Azure *and* restart Firefox?
(Reporter)

Comment 6

6 years ago
Created attachment 587957 [details]
Rendering settings

Well, in this case is online switching behaving in the same way like with cold restart.
But what could maybe have some impact on text rendering is, that I prefer to use non-antialiased fonts and my settings is like on enclosed attachment.
I've tried to change randomly some of them but without effect on this scenario, but maybe it could give you some clue...
(Reporter)

Comment 7

6 years ago
PS: I have disabled cleartype/alliasing for whole OS,not just browser. With this Azure rendering in seems to force aliasing everywhere, but I understand it as temporary feature only.
PS2: Not only JPG rendering is sometimes broken (lower part of img is just black) but it happens for me almost every time also with PNGs, like one I enclosed in previous comment...
(Reporter)

Comment 8

6 years ago
It looks the same, like on screenshot, after "hot" change or after "change and restart"
I can't reproduce, using up-to-date nightly on Win7.
about:support says I've got NVIDIA NVS 3100M & AzureBackend=direct2d

I tried turning off ClearType system-wide and the cleartype.use_for_downloadable_fonts pref (from comment 6's screenshot), and restarted Firefox, for good measure -- still couldn't reproduce.

Marek -- do you hit this bug in a fresh Firefox profile?  (with no prefs tweaked?)
(note that azure is enabled by default in Nightly now)
(Reporter)

Comment 10

6 years ago
Problem for me still remains, sorry, even with fresh new profile created (I did it twice, to be sure)
Sorry... :-(
I there is no newer (except beta) driver from nVidia...

PS: And also those black-sripes on PNGs/JPGs I can still se...
(In reply to Daniel Holbert [:dholbert] from comment #9)
> I can't reproduce, using up-to-date nightly on Win7.
> about:support says I've got NVIDIA NVS 3100M & AzureBackend=direct2d
> 
> I tried turning off ClearType system-wide and the
> cleartype.use_for_downloadable_fonts pref (from comment 6's screenshot), and
> restarted Firefox, for good measure -- still couldn't reproduce.
> 
> Marek -- do you hit this bug in a fresh Firefox profile?  (with no prefs
> tweaked?)
> (note that azure is enabled by default in Nightly now)

Daniel, Azure shouldn't be enabled by default for content rendering on nightly, you still need to set gfx.content.azure.enabled to true.

Comment 12

4 years ago
WFM on Windows 7 with azure enabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.