Inserting a bookmark entry will crash on Fennec

VERIFIED DUPLICATE of bug 717396

Status

()

Firefox for Android
Android Sync
--
blocker
VERIFIED DUPLICATE of bug 717396
6 years ago
5 days ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
NPE crash when bookmarking a URL on fennec

Repro:
1) install 0.4 build, Samsung Galaxy Nexus Android 4.0.1
2) connect to firefox sync
3) launch fennec, pick any site (eg. google.com), and bookmark it 
4) Verify NPE crash

01-11 13:49:07.944: DEBUG/GeckoBrowserProvider(12452): Extracting image values for URI: http://www.google.com/
01-11 13:49:07.968: WARN/dalvikvm(12452): threadid=11: thread exiting with uncaught exception (group=0x40a581f8)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452): FATAL EXCEPTION: GeckoLooper Thread
01-11 13:49:08.124: ERROR/AndroidRuntime(12452): java.lang.NullPointerException
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.fennec_rnewman.db.BrowserProvider.insertInTransaction(BrowserProvider.java:695)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.fennec_rnewman.db.BrowserProvider.insert(BrowserProvider.java:655)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at android.content.ContentProvider$Transport.insert(ContentProvider.java:189)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at android.content.ContentResolver.insert(ContentResolver.java:729)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.db.LocalBrowserDB.addBookmark(LocalBrowserDB.java:292)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.db.BrowserDB.addBookmark(BrowserDB.java:132)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.Tab$AddBookmarkTask.doInBackground(Tab.java:415)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.Tab$AddBookmarkTask.doInBackground(Tab.java:411)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.GeckoAsyncTask$1.run(GeckoAsyncTask.java:47)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at android.os.Handler.handleCallback(Handler.java:605)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at android.os.Handler.dispatchMessage(Handler.java:92)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at android.os.Looper.loop(Looper.java:137)
01-11 13:49:08.124: ERROR/AndroidRuntime(12452):     at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:158)
01-11 13:49:08.132: WARN/ActivityManager(181):   Force finishing activity org.mozilla.fennec_rnewman/.App
01-11 13:49:08.186: INFO/GeckoApp(12452): pause
01-11 13:49:08.186: INFO/Gecko(12452): AndroidGeckoEvent: 0x41a17ec8 : 10
01-11 13:49:08.186: INFO/WindowManager(181): createSurface Window{41c7fa88  paused=false}: DRAW NOW PENDING
01-11 13:49:08.233: INFO/WindowManager(181): createSurface Window{41c38780 Toast paused=false}: DRAW NOW PENDING
01-11 13:49:08.272: INFO/WindowManager(181): createSurface Window{41ca3030 com.android.settings/com.android.settings.Settings$ManageAccountsSettingsActivity paused=false}: DRAW NOW PENDING
01-11 13:49:08.429: DEBUG/dalvikvm(181): GC_EXPLICIT freed 424K, 24% free 23431K/30727K, paused 2ms+7ms
01-11 13:49:08.577: DEBUG/dalvikvm(11298): GC_CONCURRENT freed 1205K, 7% free 18392K/19719K, paused 5ms+24ms
01-11 13:49:08.991: INFO/GeckoApp(12452): stop
01-11 13:49:08.991: INFO/Gecko(12452): AndroidGeckoEvent: 0x41a45ff8 : 9
01-11 13:49:08.991: INFO/GeckoApp(12452): destroy
01-11 13:49:08.991: INFO/Gecko(12452): AndroidGeckoEvent: 0x41a46118 : 11
01-11 13:49:08.991: DEBUG/GeckoFavicons(12452): Closing Favicons database

Expected:
- no fennec crash
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717396
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

5 days ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.