message is lost after undo delete

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Alonso Acuña, Unassigned)

Tracking

9 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

delete message with attachment. Immediately click on undo delete.


Actual results:

After delete the message dissapears and status bar shows moving message to trash.  In the meantime the undo is clicked and the message is again shown on Inbox. After a few seconds message disappears from Inbox. Message also cannot be found in Trash. Sometimes going offline and back online will show message on inbox but sometimes it is gone forever.


Expected results:

message should appear in inbox after undo.

I think the problem is when the message is large or for some reason the delete operation takes a while and undo is clicked when it has not finished. I was unable to reproduce on small messages.
Synchronization is active on inbox. Delete moves to trash.
Mail server is cyrus-imapd-2.3.7

Comment 1

6 years ago
(In reply to Alonso Acuña from comment #0)
Undoing a message deletion returns it where it was for me:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20111222 Thunderbird/9.0.1
Application Build ID: 20111222141531

Maybe this is specific to the IMAP server though.
(Reporter)

Comment 2

6 years ago
this is happening even on very small messages with no attachment and even when doing the undo 5 seconds after the initial delete.  So disregard what I said about large messages and undoing while delete is in progress.
Same problem as bug 618809?
> Unread deleted mail can not be restored from the trash folder
> with mail.server.default.dup.action = 2 (move duplicated mails to trash)

What is offline-use setting of Inbox and Trash? (Folder Properties, Synchronization)
What is UID of relevant mails? (show "Order Received" column. value is UID of mail if IMAP)
Can you attach IMAP log file? ( see bug 402793 comment #28 )
Remove/replace personal information from log file, please. And remove mail data please, because mail data itself is irrelevant to problem and required data is folder status(Inbox, Trash in your case), uid of mails, command requested by Tb, and notification/response from server for relevant mails. Please never paste data to bug at B.M.O if data is long.
Alonso ?
(Reporter)

Comment 5

6 years ago
This is not related to bug 618809. I do not have a dup.action=2 and my emails are lost forever not found in the Trash.

I have found 3 ways to avoid the problem, temporarily:
1. If I enable offline use on the Trash then the problem is mostly resolved. The only way to reproduce the error in this case is doing the delete and undo very quickly after starting TB. If I wait a few seconds I can see a lot of 
    S-Trash:CreateNewLineFromSocket: * 6941 FETCH
  in the log. After this then the error does not ocurr again.

2. Even with offline use disabled, if I first open the Trash folder and then go to Inbox to delete and undo, the message is not lost. When opening the Trash I can see the same FETCH lines as above.

3. With 2 messages in the Inbox, delete one and undo. This one is lost, but FETCH lines are seen for many messages in the Trash. Now deleting the second message and undo, message is not lost.

NOTE: after waiting some time around 15 minutes the problem presents again. For example in case #2 above after opening the Trash messages will not be lost. But wating a while then the next deleted-undo message will be lost. 

Sometimes the message appears to have been lost but when closing TB and opening again it is found in the Inbox.
Also, some messages appear to be inmune or more resistant to the problem. These messages can be deleted and recovered many times and are not lost or only lost after many times.

Please let me know if you need an imap log for any specific case but be very specific on what actions you need to log.
(Reporter)

Comment 6

6 years ago
After upgrading to TB 11.0 I am unable to reproduce the bug. The undo sometimes takes a long time , like 5 seconds to recover the message, but it hasn't failed.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.