Firefox consumes 100% CPU when typing something in address bar if you have multiple bookmarks

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: kost-bebix, Unassigned)

Tracking

9 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111228084940

Steps to reproduce:

It is similar to https://bugzilla.mozilla.org/show_bug.cgi?id=282651 , but I don't see how can I reopen that
Do you have many tags?
(Reporter)

Comment 2

7 years ago
Marco: Oh yes, I sure do.
Ok, so firefox 10 has a specific fix for people with many tags, it's currently in the beta channel if you wish to try it and report back.
(Reporter)

Comment 4

7 years ago
Marco: ok, installed firefox 10 from mozilla-next PPA, seems like it fixed the bug, but I have some feeling that it's fixed by just killing process when it starts consuming 100% for more than 3 seconds or something (because cooler still sometimes starts making sounds, but then immediately backs to normal). If I am right -- then I think the algorithm should be reviewed, if I'm wrong and the algorithm is fine -- then I gues we can close the bug.

Thank you!

Comment 5

7 years ago
openSUSE 12.1, Mozilla/5.0 (X11; Linux i686; rv:13.0a1) Gecko/20120216 Firefox/13.0a1, i was not able to reproduce this. The maximum spike was 34% CPU due to the fact that i have loaded several sites after typing their address in the address bar.

Updated

5 years ago
Component: Untriaged → Location Bar

Comment 6

4 years ago
WFM per comment 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.