Firefox 9 does not restore my windows in the same order that I left them.

RESOLVED DUPLICATE of bug 712763

Status

()

RESOLVED DUPLICATE of bug 712763
7 years ago
6 years ago

People

(Reporter: sas, Unassigned)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Upgraded from Firefox 8 to Firefox 9 on my Mac OS X 10.6.8 system.


Actual results:

I keep roughly half a dozen windows open in Firefox, each of those with multiple tabs. Since installing version 9.0.1, my windows do not restore in the same order that I left them when I quit Firefox. Also, the last window restored has the name of Mozilla Firefox rather than its actual page name.


Expected results:

Firefox 8 always restored my windows in the same order as they were when Firefox was quit.  Firefox 9 should do the same.
Do you mean bug 712763 ?
(Reporter)

Comment 2

7 years ago
Created attachment 588070 [details]
Bug Image #1 for windows order bug

As you can see in this image, I've opened my windows in the sequence in which I want them to appear starting with the bottom-most window and ending with the top-most window.  Then I quit Firefox.
(Reporter)

Comment 3

7 years ago
Created attachment 588073 [details]
Bug Image #2 for windows order bug

When I started Firefox again and my windows were restored, they were not in the same order that I left them, and they are not in MRU order nor are they in reverse order.  As you can see in this image, the second and fifth windows were opened out of order (as noted by the gaps between the windows edges).
(Reporter)

Comment 4

7 years ago
Created attachment 588079 [details]
Bug Image #3 for windows order bug

Also, the Windows menu does not at all reflect the order of the windows (as can be seen in Bug Image #3).  I expect my first opened window to appear at the top of the list, followed by the second opened window, etc. with the last opened window listed at the bottom.  This is the way that it worked in version 8 and previous versions; the order of the actual windows also worked for me as expected in previous versions.

Comment 5

7 years ago
Still, it's very likely the same issue as bug 712763.
Component: Untriaged → Session Restore
Depends on: 712763
QA Contact: untriaged → session.restore
Whiteboard: [test after bug 712763 is resolved]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
OS: Mac OS X → Windows 7
Resolution: --- → DUPLICATE
Whiteboard: [test after bug 712763 is resolved]
Duplicate of bug: 712763
No longer depends on: 712763
You need to log in before you can comment on or make changes to this bug.