Last Comment Bug 717616 - Empty jsloader and jsloader\resource directories added to the Firefox 10.0b4 installer and thereby to the installation which do not get removed on uninstall
: Empty jsloader and jsloader\resource directories added to the Firefox 10.0b4 ...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 10 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Landry Breuil (:gaston)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 08:02 PST by Paul Silaghi, QA [:pauly]
Modified: 2012-06-08 06:18 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove empty jsloader/jssubloader dirs at the end of generate_cache (1.29 KB, patch)
2012-05-10 03:16 PDT, Landry Breuil (:gaston)
mh+mozilla: review+
Details | Diff | Splinter Review

Description Paul Silaghi, QA [:pauly] 2012-01-12 08:02:58 PST
Steps to reproduce:
1. Install Firefox 10b4
2. Uninstall

Actual results:
Empty folder left: "c:\Program Files (x86)\Mozilla Firefox\jsloader\resource"

Expected results:
All data removed
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2012-01-12 11:18:26 PST
Looks like there are empty directories being added in the beta build.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/10.0b4-candidates/build1/win32/en-US/Firefox%20Setup%2010.0b4.exe

We could teach the installer to clean these sort of things up but it would be better to just not add empty / unused directories as we have always done.
Comment 2 Nick Thomas [:nthomas] 2012-01-12 12:59:01 PST
They're also present in installers going all the way back to 8.0b1, so this would probably changed in the 6 weeks Fx8 was development on mozilla-central.
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2012-01-12 13:57:57 PST
I think this was caused by bug 655678. I suspect that all that is needed is the removal of the jsloader dir along with its contents as the last action in
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/packager.mk#460
Comment 4 Brian R. Bondy [:bbondy] 2012-01-12 15:58:28 PST
I wanted to mention previously that I seen this too but forgot.
Comment 5 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-13 13:00:46 PST
Paul, can you confirm that this only happens on Windows 7 (as per the Platform field in this bug)?
Comment 6 Paul Silaghi, QA [:pauly] 2012-01-16 02:11:00 PST
Same behavior on Win XP and Vista. But I would say this is reproducible on all Windows.
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-16 07:38:12 PST
(In reply to Paul Silaghi [QA] from comment #6)
> Same behavior on Win XP and Vista. But I would say this is reproducible on
> all Windows.

...and what about Linux and Mac?
Comment 8 Paul Silaghi, QA [:pauly] 2012-01-16 07:46:25 PST
There is no installer on Mac and Linux
Comment 9 Nick Thomas [:nthomas] 2012-01-16 14:25:28 PST
The jsloader dirs are actually present in the linux tarballs (32 and 64bit builds), but not included in the mac dmg.
Comment 10 Landry Breuil (:gaston) 2012-05-10 02:03:20 PDT
Starting with firefox 13.0beta i'm also seeing an empty jssubloader/185/resource/ dir, along jsloader/resource/. This is after 'make install' when building from a source tarball on OpenBSD (so, a unix platform). jsloader/resource appeared between 7.0.1 and 8.0.1 and is present in releases too, not only betas.
Comment 11 Landry Breuil (:gaston) 2012-05-10 03:16:46 PDT
Created attachment 622672 [details] [diff] [review]
Remove empty jsloader/jssubloader dirs at the end of generate_cache

This patch seems to fix the issue for me, i've generated a package through make package which didnt contain jsloader nor jssubloader dirs. Only tested on OpenBSD, so maybe worth a try run ?
Comment 13 Joe Drew (not getting mail) 2012-05-10 18:43:54 PDT
https://hg.mozilla.org/mozilla-central/rev/a0a502079098
Comment 14 Paul Silaghi, QA [:pauly] 2012-05-16 02:19:20 PDT
Verified fixed on FF 15.0a1 (2012-05-15) on Win 7, Ubuntu 12.04 and Mac OS 10.6. No more jsloader dirs on FF packages.
Comment 15 Landry Breuil (:gaston) 2012-05-18 07:24:44 PDT
Is it worth backporting to aurora/beta ?
Comment 16 Simona B [:simonab ] 2012-06-08 06:15:29 PDT
A webapprt directory is now left in the installation folder when uninstalling Firefox 15.0a2. What could cause this?
Comment 17 Brian R. Bondy [:bbondy] 2012-06-08 06:18:17 PDT
> A webapprt directory is now left in the installation folder when
> uninstalling Firefox 15.0a2. What could cause this?

The web app work introduced that regression.  Details can be found here: Bug 757978

Note You need to log in before you can comment on or make changes to this bug.