Closed Bug 717663 Opened 8 years ago Closed 8 years ago

Crash when opening about:support with abort message: "X_FreeGC: BadGC (invalid GC parameter); 5 requests ago" when WebGL is forced enabled

Categories

(Core :: Canvas: WebGL, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 589546

People

(Reporter: evilpie, Unassigned)

Details

(Keywords: crash, reproducible)

Crash Data

Running nightly build, about:support crashes instantly for me. Interestingly with different stacks.

Eg.
https://crash-stats.mozilla.com/report/index/bp-172f3d6d-92e0-4564-828c-
https://crash-stats.mozilla.com/report/index/bp-1fe9582c-646c-4a32-8917-2f0382120112

At the moment this 100% reproducible for me, so if you want me debug anything?
(In reply to Tom Schuster (evilpie) from comment #0)
> https://crash-stats.mozilla.com/report/index/bp-172f3d6d-92e0-4564-828c-
This one is truncated.
Severity: normal → critical
Crash Signature: [@ js::MaybeGC ] → [@ js::MaybeGC] [@ mozalloc_abort | NS_DebugBreak_P | X11Error]
Keywords: crash
Can you find the regression range, for instance by using http://harthur.github.com/mozregression/?
Keywords: reproducible
does it crash also if you started in safe mode?
It tried using mozregression, but not one of these builds crashed?!
Yes, same crash in safe-mode, but they all were mozalloc_abort now.
I added the new TouchBadMemory crash signature that replaces crash signatures starting by mozalloc on Linux.
Crash Signature: [@ js::MaybeGC] [@ mozalloc_abort | NS_DebugBreak_P | X11Error] → [@ js::MaybeGC] [@ mozalloc_abort | NS_DebugBreak_P | X11Error] [@ TouchBadMemory]
Depends on: 722044
I still get this crash every time, I try to open about:support.
(In reply to Tom Schuster (evilpie) from comment #7)
> I still get this crash every time, I try to open about:support.
As there were previously two crash signatures, can you provide recent crash IDs related to this issue?
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Summary: Crash when opening about:support → Crash when opening about:support with abort message: "X_FreeGC: BadGC (invalid GC parameter); 5 requests ago"
Version: 12 Branch → Trunk
Can you submit a crash report from a run with MOZ_X_SYNC=1 in the environment, please?

The [@ js::MaybeGC ] report looks quite different.
Perhaps a modern version of bug 633845.
Strange that a GL Context is created when glxtest failed.

Could webgl.force-enabled somehow be set in about:config?
Component: Widget: Gtk → Graphics
QA Contact: gtk → thebes
Component: Graphics → Canvas: WebGL
QA Contact: thebes → canvas.webgl
(In reply to Karl Tomlinson (:karlt) from comment #11)
> Strange that a GL Context is created when glxtest failed.
> 
> Could webgl.force-enabled somehow be set in about:config?
Yes, I hope this doesn't make this bug invalid. I must have this enabled quite a while back, but it never helped so I probably forgot about it. Disabling it, stops the crash.

Good Catch :)
Summary: Crash when opening about:support with abort message: "X_FreeGC: BadGC (invalid GC parameter); 5 requests ago" → Crash when opening about:support with abort message: "X_FreeGC: BadGC (invalid GC parameter); 5 requests ago" when WebGL is forced enabled
Duplicate of bug 667439, which is a duplicate of bug 589546.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589546
No longer depends on: 722044
You need to log in before you can comment on or make changes to this bug.