If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When typing text with vkb, page doesn't scroll to keep caret in view

RESOLVED DUPLICATE of bug 705106

Status

()

Firefox for Android
General
P3
normal
RESOLVED DUPLICATE of bug 705106
6 years ago
5 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: kats)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -, fennec15+)

Details

(URL)

(Reporter)

Description

6 years ago
Tested on the LG Optimus Black in portrait mode.
I've also seen this in XUL Fennec.

Steps to reproduce:
- Go to http://people.mozilla.org/~mwargers/tests/autocomplete_forms/textinput_form.html
- Tap on the input at the top, vkb comes up
- Pinch-zoom in at the maximum level, make sure that the caret is out of view
- Begin typing on the vkb

Expected result:
- After the first character, the caret gets into view again.

Actual result:
- No scroll movement at all, the caret stays out of view.

Comment 1

6 years ago
although not classic IME, alex, can you take a look?  reassign if required.
Assignee: nobody → alexp
tracking-fennec: --- → 12+
Priority: -- → P3
more of a kats bug I think
Assignee: alexp → bugmail.mozilla
blocking-fennec1.0: --- → ?
tracking-fennec: 12+ → 15+
blocking-fennec1.0: ? → -
related to bug 745667 and bug 737823?
Summary: Typing text with vkb doesn't scroll into view in this case with high zoom level → When typing text with vkb, page doesn't scroll to keep caret in view
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705106
You need to log in before you can comment on or make changes to this bug.