Closed Bug 717704 Opened 10 years ago Closed 10 years ago

Pinch zooming out, releasing one finger, then tapping on the gray removes bounce back movement

Categories

(Firefox for Android Graveyard :: General, defect, P3)

ARM
Android
defect

Tracking

(firefox13 verified)

VERIFIED FIXED
Tracking Status
firefox13 --- verified

People

(Reporter: martijn.martijn, Assigned: kats)

References

Details

Attachments

(2 files)

(Sorry for the bad summary, I didn't know of a better one)

Steps to reproduce:
- Go to a page that can be zoomed in/out
- Pinch zoom out, until you see a large gray area around the page
- Release one finger
- Pinch with the released finger on the gray area
- Release the other finger

Expected result:
- The page reverts to the default zoom level

Actual result:
- The page stays in the zoomed out level
Attached image Screenshot
This is the screenshot of the state that I get in after the str.
Assignee: nobody → bugmail.mozilla
OS: Windows 7 → Android
Hardware: x86 → ARM
tracking-fennec: --- → ?
Just to be clear, are both your fingers off the screen at the end? Your STR ends while one finger is still on the gray area, so I want to make sure you've released both fingers when you see this.
Yes.

Sorry, this step:
- Pinch with the released finger on the gray area

Should be:
- Tap with the released finger on the gray area
I made a video out of this:
http://www.youtube.com/watch?v=9YkdqVKSHP0&feature=g-upl&context=G2a8c024AUAAAAAAAAAA
The bug doesn't always occur the first time, but on second try, the bug occured in this video.
tracking-fennec: ? → 11+
Priority: -- → P3
I'm able to reproduce this pretty consistently on the Droid Pro, but it doesn't happen if I tap on the gray area. It happens if I tap in the black area around the screen. This is very similar to the thing I described in bug 718970, it seems to be a case where the system ScaleGestureDetector doesn't handle properly, since it gets incorrectly stuck in a pinch state. The ScaleGestureDetector rewrite (bug 706684) might fix this; I will rebuild with that and verify.
Depends on: 706684
The issue I was seeing has been fixed with the ScaleGestureDetector rewrite (bug 706684). Please re-test on the latest nightly to see if the original issue is still happening. (If you're testing on an Android 2.2 device you'll need to wait for the new nightly that's being spun now so you get https://hg.mozilla.org/mozilla-central/rev/cd76470c9e6f as well, or use the debug build I uploaded to https://people.mozilla.com/~kgupta/tmp/0d5ad6a6f814.apk)
Yes, this is fixed now in the latest trunk build, thanks.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Removing tracking-fennec; we're tracking the fix in bug 706684.
tracking-fennec: 11+ → ---
Verified fixed on:
Nightly Fennec 13.0a1 (2012-03-06)
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.