Last Comment Bug 717757 - GCLI doorhanger eats mouse click
: GCLI doorhanger eats mouse click
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: x86_64 Linux
: P3 normal (vote)
: Firefox 15
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 720641
Blocks: 745773
  Show dependency treegraph
 
Reported: 2012-01-12 14:20 PST by Stefan
Modified: 2012-05-21 01:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screencast (1.07 MB, video/ogg)
2012-01-17 10:19 PST, Stefan
no flags Details

Description Stefan 2012-01-12 14:20:22 PST
User Agent:  

Steps to reproduce:

1. Open http://dev.deconcept.com/referer_tester/ (needs Flash)
2. Enable Web console (shift-ctrl-k).
3. Click at the "PushMe" button (flash).
4. Click at the Line "GET http://..."


Actual results:

4. Doorhanger flicker.


Expected results:

4. Window "Inspect Network request" opens.
Comment 1 Michael Ratcliffe [:miker] [:mratcliffe] 2012-01-17 10:01:19 PST
I am not able to reproduce this. Can you try again and let us know whether it is working for you?
Comment 2 Stefan 2012-01-17 10:19:55 PST
Created attachment 589230 [details]
screencast
Comment 3 Stefan 2012-01-17 10:22:07 PST
(In reply to Michael Ratcliffe from comment #1)
> I am not able to reproduce this. Can you try again and let us know whether
> it is working for you?

Fx is still eating the mouse click.
Comment 4 Panos Astithas [:past] 2012-01-18 00:34:03 PST
Cannot reproduce this on OS X nightlies. Might be a Linux-only thing. Which distro and window manager are you using?
Comment 5 Stefan 2012-01-18 04:37:52 PST
openSUSE 11.1 (Evergreen). KDE.
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-24 02:54:12 PST
We've preffed off GCLI pending some UX changes, and I suspect the hints-slide-in-from-the-left thing that's probably part of causing this won't be part of the new way of doing things.

We should loop back and check when we enable the new UX.
Thanks for the report.
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 10:33:13 PDT
Bug 720641, has now landed, which puts GCLI in a different position, so I expect that this bug will go away.
To pref on, use devtools.toolbar.enable and open the developer toolbar.
I'll assume this is fixed unless I hear otherwise.
Thanks!
Comment 8 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-04-29 11:57:23 PDT
GCLI Triage.
Comment 9 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-05-16 00:52:34 PDT
The new feature is different enough that I'm assuming this is fixed.

Note You need to log in before you can comment on or make changes to this bug.