500 Internal Server Error on graph-icon

RESOLVED DUPLICATE of bug 718247

Status

--
critical
RESOLVED DUPLICATE of bug 718247
7 years ago
7 years ago

People

(Reporter: stephend, Assigned: brandon)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
STR:

1. Load https://crash-stats.allizom.org/topcrasher/byversion/Firefox/9.0.1
2. Click on the graph-icon for this stack: https://crash-stats.allizom.org/report/list?range_value=7&range_unit=days&date=2012-01-11&signature=hang%20%7C%20mozilla%3A%3Aplugins%3A%3APPluginInstanceParent%3A%3ACallPBrowserStreamConstructor%28mozilla%3A%3Aplugins%3A%3APBrowserStreamParent%2A%2C%20nsCString%20const%26%2C%20unsigned%20int%20const%26%2C%20unsigned%20int%20const%26%2C%20mozilla%3A%3Aplugins%3A%3APStreamNotifyParent%2A%2C%20nsCString%20const%26%2C%20nsCString%20const...&version=Firefox%3A9.0.1

Expected:

Graph works

Actual:

[14:49:23.243] GET https://crash-stats.allizom.org/topcrasher/plot_signature/Firefox/9.0.1/hang%20%7C%20mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor(mozilla::plugins::PBrowserStreamParent*,%20nsCString%20const&,%20unsigned%20int%20const&,%20unsigned%20int%20const&,%20mozilla::plugins::PStreamNotifyParent*,%20nsCString%20const&,%20nsCString%20const.../2012-01-04/2012-01-11/ [HTTP/1.1 500 Internal Server Error 3711ms]

Stack, below:

    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,530 DEBUG - Dummy-7 - SignatureHistory __init__
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,531 ERROR - Dummy-7 - Caught Error: <type 'exceptions.ValueError'>
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,531 ERROR - Dummy-7 - need more than 1 value to unpack
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,531 ERROR - Dummy-7 - trace back follows:
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,532 ERROR - Dummy-7 - Traceback (most recent call last):
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,532 ERROR - Dummy-7 - File "/data/socorro/application/socorro/webapi/webapiService.py", line 60, in GET#012    result = self.get(*args)
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,532 ERROR - Dummy-7 - File "/data/socorro/application/socorro/services/signatureHistory.py", line 30, in get#012    convertedArgs))
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,533 ERROR - Dummy-7 - File "/data/socorro/application/socorro/webapi/webapiService.py", line 20, in <genexpr>#012    return (t(v) for t, v in zip(type_converters, values_to_convert))
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,533 ERROR - Dummy-7 - File "/data/socorro/application/socorro/lib/datetimeutil.py", line 86, in string_to_datetime#012    re.sub('(\d)\s(\d)', r'\1T\2', date))
    Jan 12 14:48:58 Socorro Web Services (pid 18881): 2012-01-12 14:48:58,533 ERROR - Dummy-7 - File "/usr/lib/python2.6/site-packages/isodate/isodatetime.py", line 48, in parse_datetime#012    datestring, timestring = datetimestring.split('T')
(Assignee)

Updated

7 years ago
Assignee: nobody → bsavage
Pretty sure comment 0 is the wrong stack, it's actually:

2012-01-12 15:53:22 -08:00 --- error: [5xx Error] File: application/controllers/topcrasher.php; Line: 289; Message: Missing argument 5 for Topcrasher_Controller::plot_signature()

We do have a lot of errors like comment 0 though, would be good to track those down...

Comment 2

7 years ago
Commits pushed to https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/df3238d31e19aa50b14ebe8618909a95cd9807f7
Fixes Bug 717771 - Though it doesn't fix the initial cause of this bug - the fact that the URL was malformed and the function wasn't receiving proper data - it does fix a very problematic section of code that was causing a similar stack trace to occur when the function received the proper information.

https://github.com/mozilla/socorro/commit/bf9e588cc27944908b0d4e696308910b1f401652
Merge pull request #278 from brandonsavage/bug717771

Fixes Bug 717771 - Though it doesn't fix the initial cause of this bug -...

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 3

7 years ago
Commit pushed to https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/f744cd4053698c649cdcf1d4b04c82bcd7b2bee9
Fixes Bug 717771 - Though it doesn't fix the initial cause of this bug - the fact that the URL was malformed and the function wasn't receiving proper data - it does fix a very problematic section of code that was causing a similar stack trace to occur when the function received the proper information.
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: --- → 2.4

Comment 4

7 years ago
What's the status here?  Should this move to 2.4.1 or are we going to ship a 2.4.0.1?
(Assignee)

Comment 5

7 years ago
There were two issues here: the stack trace with the UTC incompatibility, and the missing argument. The first shipped in 2.4 and was a regression on the 2.3.x series. The second was not a regression, as it was a bug in the 2.3.x series, and should ship in 2.4 (Bug 718247).
(Assignee)

Comment 6

7 years ago
Marked as duplicate because the later bug was actually fixed.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718247
You need to log in before you can comment on or make changes to this bug.