Last Comment Bug 717773 - Crash [@ SpdySession::LogIO] on gmail
: Crash [@ SpdySession::LogIO] on gmail
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: 11 Branch
: All All
: -- critical (vote)
: mozilla12
Assigned To: Honza Bambas (:mayhemer)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 14:54 PST by Honza Bambas (:mayhemer)
Modified: 2012-01-25 07:10 PST (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.37 KB, patch)
2012-01-12 14:54 PST, Honza Bambas (:mayhemer)
mcmanus: review+
honzab.moz: checkin+
Details | Diff | Review
v1 - part 2 (1.46 KB, patch)
2012-01-14 07:52 PST, Honza Bambas (:mayhemer)
mcmanus: review+
Details | Diff | Review

Description Honza Bambas (:mayhemer) 2012-01-12 14:54:20 PST
Created attachment 588197 [details] [diff] [review]
v1

Read location exception at:

    PR_snprintf(line, 128 - (line - linebuf), "%02X ",
>                ((unsigned char *)data)[index]);


 	xul.dll!mozilla::net::SpdySession::LogIO(mozilla::net::SpdySession * self=0x0ec18e88, mozilla::net::SpdyStream * stream=0x14ac8610, const char * label=0x57807f54, const char * data=0x138d33b7, unsigned int datalen=90313168)  Line 172 + 0x6 bytes	C++
	xul.dll!mozilla::net::SpdyStream::TransmitFrame(const char * buf=0x138d33b7, unsigned int * countUsed=0x05c1f4c4)  Line 533 + 0x20 bytes	C++
 	xul.dll!mozilla::net::SpdyStream::OnReadSegment(const char * buf=0x138d33b7, unsigned int count=10697, unsigned int * countRead=0x05c1f4c4)  Line 795 + 0x10 bytes	C++
 	xul.dll!nsHttpTransaction::ReadRequestSegment(nsIInputStream * stream=0x130c1228, void * closure=0x130c1010, const char * buf=0x138d33b7, unsigned int offset=20071, unsigned int count=10697, unsigned int * countRead=0x05c1f4c4)  Line 470 + 0x1e bytes	C++
 	xul.dll!nsBufferedInputStream::ReadSegments(unsigned int (nsIInputStream *, void *, const char *, unsigned int, unsigned int, unsigned int *)* writer=0x559c354b, void * closure=0x130c1010, unsigned int count=12697, unsigned int * result=0x05c1f5a0)  Line 378 + 0x3d bytes	C++
 	xul.dll!nsHttpTransaction::ReadSegments(nsAHttpSegmentReader * reader=0x14ac8610, unsigned int count=32768, unsigned int * countRead=0x05c1f5a0)  Line 499 + 0x2d bytes	C++
 	xul.dll!mozilla::net::SpdyStream::ReadSegments(nsAHttpSegmentReader * reader=0x0ec18e90, unsigned int count=32768, unsigned int * countRead=0x05c1f5a0)  Line 124 + 0x27 bytes	C++
 	xul.dll!mozilla::net::SpdySession::ReadSegments(nsAHttpSegmentReader * reader=0x0b23e200, unsigned int count=32768, unsigned int * countRead=0x05c1f5a0)  Line 1233 + 0x2c bytes	C++
 	xul.dll!nsHttpConnection::OnSocketWritable()  Line 984 + 0x2a bytes	C++
 	xul.dll!nsHttpConnection::OnOutputStreamReady(nsIAsyncOutputStream * out=0x0b0d6d08)  Line 1218 + 0xb bytes	C++
 	xul.dll!nsSocketOutputStream::OnSocketReady(unsigned int condition=0)  Line 525	C++
 	xul.dll!nsSocketTransport::OnSocketReady(PRFileDesc * fd=0x0b268e98, short outFlags=3)  Line 1565	C++
 	xul.dll!nsSocketTransportService::DoPollIteration(bool wait=true)  Line 759 + 0x21 bytes	C++
 	xul.dll!nsSocketTransportService::Run()  Line 645	C++


Locals at crash frame:
		datalen	90313168	unsigned int
		index	4312137	unsigned int


Locals from 	SpdyStream::TransmitFrame:
		avail	0x00000199	unsigned int
		rv	0x80470007	unsigned int
		offset	0x00000000	unsigned int
		transmittedCount	0x056211d0	unsigned int


Apparently you have to move LogIO call after the NS_FAILED check since it is dependent on transmittedCount value that may not be valid.

STR:
I was sending my self an email with 500MB attachment using gmail web UI
- [write new]
- add the file attachment (select file)
=> after a time crash
Comment 1 Patrick McManus [:mcmanus] 2012-01-12 14:56:41 PST
oh man :)

module the log problem, did the 1/2 gb attachment work?
Comment 2 Honza Bambas (:mayhemer) 2012-01-12 15:09:02 PST
Cannot send even w/o SPDY.

however:
- w/o spdy on: error no is #008
- when I during the same browser session (no restart) turn spdy on, it takes some 30-40 secs to get a response after pressing send and error is #103
- when composing the mail with spdy enabled from the start of the browser session the error is also #103

A different bug, though.  Maybe worth to report and investigate.
Comment 3 Honza Bambas (:mayhemer) 2012-01-12 15:10:31 PST
(In reply to Honza Bambas (:mayhemer) from comment #2)
> - when composing the mail with spdy enabled from the start of the browser
> session the error is also #103

And I get it immediately, forgot to mention.
Comment 5 Marco Bonardo [::mak] 2012-01-14 01:37:27 PST
https://hg.mozilla.org/mozilla-central/rev/9fab07be5d36
Comment 6 Honza Bambas (:mayhemer) 2012-01-14 07:52:43 PST
Created attachment 588635 [details] [diff] [review]
v1 - part 2

I think this needs to be updated too.
Comment 7 Honza Bambas (:mayhemer) 2012-01-14 08:04:30 PST
?
Comment 8 Patrick McManus [:mcmanus] 2012-01-14 08:21:34 PST
Comment on attachment 588635 [details] [diff] [review]
v1 - part 2

That was supposed to be a plus. I think my scroll-wheel changed it while I was looking for the submit button. sorry.
Comment 9 Patrick McManus [:mcmanus] 2012-01-24 13:09:35 PST
9fab07be5d36
Comment 10 Scoobidiver (away) 2012-01-24 14:38:10 PST
(In reply to Patrick McManus [:mcmanus] from comment #9)
> 9fab07be5d36
It's the changeset of part 1, not part 2.
Comment 11 Patrick McManus [:mcmanus] 2012-01-24 14:51:54 PST
honza, can I check in p2?
Comment 12 Honza Bambas (:mayhemer) 2012-01-24 15:10:02 PST
(In reply to Patrick McManus [:mcmanus] from comment #11)
> honza, can I check in p2?

UPS!!  Yes please.
Comment 13 Patrick McManus [:mcmanus] 2012-01-24 18:23:17 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef5bc6a47bd5
Comment 14 Scoobidiver (away) 2012-01-25 00:46:37 PST
Is Fx 11 affected?
Comment 15 Patrick McManus [:mcmanus] 2012-01-25 05:49:58 PST
(In reply to Scoobidiver from comment #14)
> Is Fx 11 affected?

affected, yes. but its not meaningful or worth a port - this is an NSPR_LOGGING only issue.
Comment 16 :Ms2ger 2012-01-25 07:10:11 PST
https://hg.mozilla.org/mozilla-central/rev/ef5bc6a47bd5

No need for the [inbound], thanks.

Note You need to log in before you can comment on or make changes to this bug.