crash on a page with flash/video when I rotated the screen

RESOLVED WORKSFORME

Status

()

P3
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: mluna, Assigned: snorp)

Tracking

({crash})

11 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MTD][native-crash], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 588248 [details]
verbose log from DDM

Web page or screen you were on when you saw the issue: http://www.theblaze.com/stories/taiwanese-reporter-tests-out-slide-freaks-out-big-time

Steps to reproduce:
1. I opened the GMail app to read an email from my Dad, subject line 'Too Funny!'
2. I tapped the link in the email, chose Aurora to open the link, and arrived at the page above, the video appeared black with the big play triangle
3. I rotated the phone and Firefox Aurora crashed, showing me the crash report

What you expected: I expected to be able to click the play button and watch the video. I was able to reproduce the crash today, so I'm attaching the log file. The crash reporter didn't appear for today's crash(es). So, we have a crash report from yesterday and a log from today. Hope this helps.

Crash report ID (if applicable): bp-8fdd9b7c-1e90-480c-8ea2-248292120111
Crash Signature: [@ libflashplayer.so@0x13042e ]
Keywords: crash
Whiteboard: [MTD] → [MTD][native-crash]

Comment 2

7 years ago
Which version of Flash do you use (the crash signature depends on the Flash version)?
Severity: major → critical
Crash Signature: [@ libflashplayer.so@0x13042e ] → [@ libflashplayer.so@0x13042e]
Depends on: 704161

Comment 3

7 years ago
snorp, could this just be the gralloc crash/failure we saw about 2weeks ago?
Assignee: nobody → snorp
mluna: does this still reproduce for you with the latest Aurora Build?
(Reporter)

Comment 5

7 years ago
I cannot reproduce a crash with yesterday's build and the flash video plays fine now and plays through device rotation. 

(However, it took a long time to actually load the page and I saw that 'BadTouch' message someone was asking about last week in the log at one point. I was tapping the play button and it went back to Gmail, so I clicked the link again, and it loaded in a new tab, and this second time I was able to load the page and watch the not very funny video. So let me know if you want me to test some more for BadTouch.)
mluna: thank you. setting this to resolved; pls. file a new bug covering 'badtouch' case with steps to reproduce/note how frequently you run into this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.