Extra newlines appear after blank lines in textareas and plain text

RESOLVED DUPLICATE of bug 716229

Status

()

Core
Layout: Text
--
major
RESOLVED DUPLICATE of bug 716229
6 years ago
6 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({regression, testcase})

12 Branch
x86_64
Linux
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Load a page with a textarea, like data:text/html,<textarea>
2. Focus the textarea
3. Press the return key to insert a blank line
4. Type an "x" on the next line

Expected results: The textarea contains one blank line followed by an "x".

Actual results: The textarea contains two blank lines followed by an "x".  (Actually, it based on cursor movement, it looks like there's actually one newline character, but the blank line has a margin below it adding an extra line worth of blank space.)

I'm seeing this in recent mozilla-central nightlies on Debian and Ubuntu, including the current one (Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120112 Firefox/12.0a1).  I'll search for a regression range next.
(Reporter)

Comment 1

6 years ago
Based on bisecting nightlies, this regressed between the 2012-01-06 build and the 2012-01-07 build.  The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c7e27452a143&tochange=5a446202be5f

Maybe related to bug 703100?
This sounds like bug 716229, which should now be fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 716229

Comment 3

6 years ago
I can confirm on 
http://hg.mozilla.org/mozilla-central/rev/8ffdb4c7404a
Mozilla/5.0 (X11; Linux i686; rv:12.0a1) Gecko/20120112 Firefox/12.0a1 ID:20120112031044
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

6 years ago
Blocks: 703100

Comment 4

6 years ago
Triggered by:
05fff11a2781	Jonathan Kew — bug 703100 - pt 1 - eliminate gfxTextRunWordCache and gfxTextRunCache. r=roc

Comment 5

6 years ago
Created attachment 588349 [details]
testcase01 (plain text)

If 1st line is blank, the line height is double.

Comment 6

6 years ago
Created attachment 588350 [details]
Screenshot for testcase01

Comment 7

6 years ago
Created attachment 588351 [details]
textarea

put caret before aaaaaaaaaa and push return key.
put caret before bbbbbbbbbb and push return key.

Updated

6 years ago
Summary: Extra newlines appear after blank lines in textareas → Extra newlines appear after blank lines in textareas and plain text
I'm not seeing this on my Linux machine, although I have a guess what's causing the problem. Could you please verify what fonts are being used, including the initial newline (either try Select All and then Show Fonts in Selection, or check the Fonts panel in Page Info - with the fontinfo addon).

Comment 9

6 years ago
*Plain text
wasy10
Bitstream Vera Sans Mono


*Textaera
wasy10
(Reporter)

Comment 10

6 years ago
I am seeing "wasy10" used in both testcases.
Status: REOPENED → NEW
Keywords: testcase
(Reporter)

Updated

6 years ago
Component: Editor → Layout: Text
QA Contact: editor → layout.fonts-and-text

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 716229
You need to log in before you can comment on or make changes to this bug.