about:firefox comes without background image

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P4
normal
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Jan Manthay, Assigned: snorp)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 588409 [details]
about:firefox page, no background image

When opening about:firefox, the about page comes without the background image.

This happens on an Archos 70 Internet Tablet with Android 2.2.1

This does NOT happen on a Sony Ericsson Xperia Mini with Android 2.3.4
Hi Jan,

On your Archos 70, can you capture and attach a log as your open about:firefox? You can do so by using Alogcat (https://market.android.com/details?id=org.jtb.alogcat) off of the Android Market.
(Reporter)

Comment 2

6 years ago
Created attachment 588424 [details]
Logfile from the start of Aurora, and then open about:firefox

This is the first time I am using this tool, so I hope it is Ok.
The log is from the start of Aurora, and then open about:firefox
I think I know what the problem is here. the background images are using the wrong URL for the froyo theme. I have a fix in a patch on bug 704415.
Created attachment 588462 [details]
logcat attached.  EGL issue.

I have had a similar experience with the HTC Thunderbolt.  I uninstalled fennec and reinstalled it and it did come in.  However, I still have issues where none of the pages are loading properly.  Jan, can you check to see if you have the same issue when you uninstall and reinstall?

I will attach my own log here : mine may be a separate issue.  If it is I will separate it out from this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Firefox 11 → Trunk
(Reporter)

Comment 5

6 years ago
I have uninstalled and reinstalled Aurora several times so far, there was no effect.
This also affecs the Nightly Builds (12) btw.

Comment 6

6 years ago
snorp, gralloc?
Assignee: nobody → snorp
tracking-fennec: --- → +
Priority: -- → P4
Can you try the latest nightly? According to your log, we tried to use gralloc on your device and failed, which may have caused issues. The current nightly should not do that.
(Reporter)

Comment 8

6 years ago
Build 2012-01-24
It´s OK now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.