Closed Bug 717934 Opened 9 years ago Closed 2 years ago

After redirection, always show the destination entry in the History panel

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nicolas.barbulesco, Unassigned)

Details

Hi,

Firefox 9.0.1.

Look at these examples :

www.getfirefox.com
www.getthunderbird.com
fr.wikipedia.org
en.wikipedia.org

These addresses redirect from what I'll call origin to what I'll call destination. Let's call the entries in the History origin entry and destination entry. In the History panel, the destination entry often appears, but not always. I expect it to appear always. The current behaviour I encounter is inconsistent.

I open Firefox. I clear the cache and my History. I display the History panel, which is empty. The view is "By Last Visited". I go to "www.getfirefox.com". In the History panel, I get the source entry, but not the destination entry. I now go to "www.getthunderbird.com". In the History panel, I get the new source entry, but not the new destination entry. And I still don't see the getfirefox destination entry. I switch the History panel to another view, then back to "By Last Visited". Now, I see all the destination entries. I now go to "en.wikipedia.org". In the History panel, I get the Wikipedia source entry, but not the Wikipedia destination entry. I even click on the Wikipedia logo on the page : this is a link to "http://en.wikipedia.org/wiki/Main_Page". The page loads again, but I still don't see the Wikipedia destination entry in my History. Again, I switch the view and then back to view "By Last Visited". Now, I see the Wikipedia destination entry in my History. Now, I go to "www.getfirefox.com". The bug does not occur : the getfirefox source and destination entries go up.

At any step, if I switch the History panel to another view, then back to "By Last Visited", I see all the entries. It means this : whenever an entry is missing from the History view, in fact the entry is well in the History, but Firefox just forgets to show it in the view.

Thanks for correcting that.

Cheers,

Nicolas
All four servers in comment 0 send "HTTP/1.1 301 Moved Permanently" so i assume that is the reason for not preserving the history.
Thomas,

Please run all the steps I detailed on Firefox 9.0.1.

The History *is* preserved. And it is shown fully, in most cases. Just in certain situations, the History is not fully shown at once but however it is shown fully when I re-generate its display.
The current behaviour is inconsistent.
Firefox correctly saves and manages the entries in the History. But Firefox just does not update enough the display in the History panel.

Nicolas
Blocks: useragent
No longer blocks: useragent
As far as I can tell this is working in the latest Firefox nightly (61a1). The destination addresses are always displayed in history.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.