Closed Bug 718149 Opened 8 years ago Closed 8 years ago

Sync button doesnt launch account settings after being setup

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox11 --- verified
fennec + ---

People

(Reporter: tchung, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot
Regression.   Once Firefox Sync account is setup, clicking the Firefox Sync button will no longer launch the account settings page.  Instead, it throws a message saying "Only one Firefox Sync account is supported"

Workaround is to go through android settings > accounts.  

See screenshot

Repro:
1) install rnewman's 0.5 1-13-2011 Fennec sync build
2) setup sync via account manager
3) click the Firefox Sync button.  
4) Verify client error fires instead of taking user to Account Settings

Expected:
- clicking Firefox Sync button should launch account settings

Actual:
- client error thrown saying "Only one Firefox Sync account is supported"
Blocks: 718242
Duplicate of this bug: 718495
Redirects to Account Settings screen, where user can select Firefox Sync account from list. (Firefox Sync icon does not obviously identify Firefox, so not quite ideal.)

https://github.com/mozilla-services/android-sync/commit/98cecd7775e6f9e1aaacecdbedb2365323be6902
tracking-fennec: --- → ?
tracking-fennec: ? → +
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 720933
verified with m-c build from 20120126
Status: RESOLVED → VERIFIED
Should be working fine in Aurora, modulo Bug 721760.
verified on Fx11
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.