sessionstore prefs not in about:support

VERIFIED FIXED in mozilla13

Status

()

Toolkit
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: cilias, Assigned: aryx)

Tracking

Trunk
mozilla13
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [inbound], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
STR:
1. Go to about:config and set browser.sessionstore.max_resumed_crashes to 0.
2. Go to about:support.

Result:
browser.sessionstore.max_resumed_crashes is not listed under "Modified Preferences". 

Expected result:
browser.sessionstore.max_resumed_crashes should be listed under "Modified Preferences". 

I also tried it with browser.sessionstore.resume_from_crash, so assume it applies to all sessionstore prefs.

Tested on Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120113 Firefox/12.0a1
Created attachment 594471 [details] [diff] [review]
patch addind browser.sessionstore. to the whitelist of modified preferences to show

This patch adds browser.sessionstore. to the whitelist of preferences which will be shown in about:support if they have been modified.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #594471 - Flags: review?(dtownsend+bugmail)
Comment on attachment 594471 [details] [diff] [review]
patch addind browser.sessionstore. to the whitelist of modified preferences to show

Paul can decide if it makes sense to include all of these.
Attachment #594471 - Flags: review?(dtownsend+bugmail) → review?(paul)
Comment on attachment 594471 [details] [diff] [review]
patch addind browser.sessionstore. to the whitelist of modified preferences to show

Since only the modified ones get included and they are often the cause of unexpected issues, I see no reason not to add them all.
Attachment #594471 - Flags: review?(paul) → review+
Keywords: checkin-needed

Comment 4

7 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/803d5de3ced3
Keywords: checkin-needed
Whiteboard: [inbound]

Comment 5

7 years ago
https://hg.mozilla.org/mozilla-central/rev/803d5de3ced3
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla13
(Reporter)

Comment 6

7 years ago
Verified with:
Mozilla/5.0 (Windows NT 5.1; rv:13.0a1) Gecko/20120210 Firefox/13.0a1 BuildID:20120210031150

Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.