All users were logged out of Bugzilla on October 13th, 2018

Bug 618353 reduced the space to the right of the Window controls

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: valeriopetroni, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 588628 [details]
less space to the right of the close button

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120111092507
(Reporter)

Updated

7 years ago
Blocks: 618353
Component: Untriaged → Widget: Win32
Product: Firefox → Core

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

7 years ago
Created attachment 588633 [details]
border 1px smaller

with the patch of Bug 618353, the window border is 1px smaller than that of a native windows so a good compromise to make the problem less visible would be to increase the window border of 1px in Bug 618353

Comment 2

7 years ago
We don't control the positioning of these controls. :/
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 3

7 years ago
In Thunderbird, where the titlebar is NOT being drawn into, the buttons have the same distance from the edge of the window as other programs, say Widows Explorer.  

But, in Firefox, where drawing in the titlebar IS done, the buttons have little space from the edge of the window.  It looks really odd.

In fairness, the Firefox buttons have at least one extra pixel of space than how Chrome does it.  :D

Is there no way to add a little margin or padding to the caption buttons to push it more into "where they belong"?

Comment 4

7 years ago
On DWM (glass) desktops, unless we want to remove the default caption buttons and draw something custom (like Chrome) the positioning is handled by Windows. It would be easier to move the Fx button so that it matches I would think.

Updated

7 years ago
QA Contact: untriaged → win32

Updated

5 years ago
Duplicate of this bug: 903989
Duplicate of this bug: 940070

Updated

5 years ago
Duplicate of this bug: 1005656
(In reply to Jim Mathies [:jimm] from comment #2)
> We don't control the positioning of these controls. :/

Looks like dpJudas has found the cause of the 1px offset:

http://www.osnews.com/comments/27705#comment_587976 :
> Speaking of evidence, I just managed to get my test application to misbehave
> in the same way as Firefox is doing. If my test program adjusts the client
> rect as part of the WM_NCCALCSIZE(wParam=false) I get the same bug. Seems
> toying around with this value causes the DWM window frame to offset buttons
> incorrectly in a weird way.

Updated

5 years ago
Summary: Bug 618353 reduce the space to the right of the Window controls → Bug 618353 reduced the space to the right of the Window controls

Updated

5 years ago
Duplicate of this bug: 1002928
You need to log in before you can comment on or make changes to this bug.