I Cannot Type In the Address Bar

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: donb, Unassigned)

Tracking

10 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Build ID: 20120111092507

Steps to reproduce:

I was trying to navigate to another webpage via typing in the address bar.  It does this randomly and without warning.  It just did it again and I just switched to another tab where I was running Yahoo! Mail.  I read an email but was unable to respond to it because FF would not let me type anything.  I then switched to another tab where I was running Facebook.  I was reading a friend's wall, and then tried to type in a comment and FF would not let me enter any text.  Then FF started making a donk sound whenever I tried to enter a keypress.  I could not even close FF or minimize or maximize it.  I ended up terminating FF via the task manager.


Actual results:

FF did not respond to any keypresses.  It did absolutely nothing.  Restarting the browser seems to be the only way out.


Expected results:

I should have been able to type in the address box and navigate to the desired website.
(Reporter)

Comment 1

7 years ago
It just did it again.  I noticed that prior to the not being able to type at all when I click in a field, the cursor does not show but I can still type input though.

Comment 2

7 years ago
Maybe caused by an add-on. Have you tries Safe Mode ?

http://support.mozilla.org/en-US/kb/Safe Mode
(Reporter)

Comment 3

7 years ago
Its doing it again.  

I have not tried safe mode since I haven't added any add-ons in like forever.  This all started when I began using FF beta in order to fix the Yahoo! Messenger chat window issue.

I'll give safe mode a try and let you know what happens.
(Reporter)

Comment 4

7 years ago
I had no luck using safe mode as it did it once again.

I got it to reproduce by going to Hulu.com and watching a couple of videos.  Then when I decided to enter a location in the address bar, bam, text entry is no longer possible.  

I also noticed that the cursor is not visible and I am unable to see that I highlighted text either.

Comment 5

7 years ago
Did you click in the addressbar, or did you try a shortcut like ctrl-L or F6 ? There's an existing bug where a plugin (like Flash) can grab the focus, and prevent you from going to the addressbar.
(Reporter)

Comment 6

7 years ago
I always click in the addressbar or form field.  I do not use keyboard shortcuts.
(Reporter)

Comment 7

7 years ago
Ok its not reproducing on my other laptop under the same conditions but my other laptop is running Win7 and a different CPU.  

I only filed this as a bug because it first started occurring when I installed 10 beta to fix the Yahoo! Mail Chat problem.  

Maybe I have a corrupted profile.
(Reporter)

Comment 8

7 years ago
Deleting the default profile did NOT fix it.

I have noticed that going back and forth to the tab that has Hulu induces the cursor to not appear again.  If I wait 1-3 minutes though, the cursor re-appears on its own.

I am going to uninstall and re-install 10 beta.  

If that doesn't work, I am going to revert back to 9 release.
(Reporter)

Comment 9

7 years ago
It turned out to be something within my prefs.js file.  

I backed up the file and restored to defaults and that fixed the problem.  

I then put the backed up prefs.js back in and the problem re-occurred.  

I then put the restored prefs.js back in and all was well once again.
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.