Page zoomed in in this case, after dismissing vkb

VERIFIED FIXED in Firefox 11

Status

()

VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: martijn.martijn, Assigned: kats)

Tracking

({testcase})

Trunk
Firefox 12
ARM
Android
testcase
Points:
---

Firefox Tracking Flags

(firefox11 verified, firefox12 verified, fennec+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 588718 [details]
testcase

I tested this on the LG Optimus Black in portrait mode.

Steps to reproduce:
- Visit testcase
- Tap on the input, vkb comes up
- Tap somewhere outside the input

Expected result:
- No change in zoom level on the page

Actual result:
- Page gets zoomed in quite far, for some reason

Comment 1

7 years ago
kats, do you see this?
Assignee: nobody → bugmail.mozilla
tracking-fennec: --- → +
On the Galaxy Tab I see it zoom in a little. I assume that since the optimus black has a smaller screen it will appear to zoom in farther. I can investigate this.
Note for prioritization: this will only happen if the page is smaller than the screen, which should rather infrequent.
(Reporter)

Comment 4

7 years ago
It happens for me on http://www.google.com .
Created attachment 591601 [details] [diff] [review]
Patch
Attachment #591601 - Flags: review?(pwalton)
Comment on attachment 591601 [details] [diff] [review]
Patch

Review of attachment 591601 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #591601 - Flags: review?(pwalton) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/8fe66d9bdc30
status-firefox11: --- → affected
status-firefox12: --- → fixed
Target Milestone: --- → Firefox 12

Comment 8

7 years ago
https://hg.mozilla.org/mozilla-central/rev/8fe66d9bdc30
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Comment on attachment 591601 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: page zooms in when vkb is hidden (on small pages)
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile-only
Attachment #591601 - Flags: approval-mozilla-aurora?
Comment on attachment 591601 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #591601 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Nightly 13.0a1 (2012-02-01)
                  Aurora  11.0a2 (2012-02-01)
Device: LG Optimus Black Android 2.2
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
status-firefox12: fixed → verified
You need to log in before you can comment on or make changes to this bug.