Remove chromedir attributes, use -moz-locale-dir instead

RESOLVED FIXED in 1.2

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified

Details

Attachments

(1 attachment)

Assignee

Description

8 years ago
Chromedir doesn't work anymore, we have to use -moz-locale-dir.

I've found remnants in calendar-views.css and accountCentral.css
Assignee

Comment 1

8 years ago
Exchange [chromedir="rtl"] with :-moz-locale-dir(rtl)

Philipp do you give approval for beta? This doesn't work already under TB 9 and it would be good if this is fixed for the ESR release.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #588731 - Flags: review?(philipp)
Assignee

Updated

8 years ago
Assignee: richard.marti → nobody
Product: Thunderbird → Calendar
QA Contact: general → general
Assignee

Updated

8 years ago
Assignee: nobody → richard.marti
Comment on attachment 588731 [details] [diff] [review]
use -moz-locale-dir

sounds good, lets take this for beta. If you push this after Thursday, please ping me beforehand.
Attachment #588731 - Flags: review?(philipp)
Attachment #588731 - Flags: review+
Attachment #588731 - Flags: approval-mozilla-beta+
Attachment #588731 - Flags: approval-mozilla-aurora+
Duplicate of this bug: 532102
According to the original calendar bug 532102 all occurrences of chromedir="&locale.dir;" can be removed too.
Assignee

Comment 5

8 years ago
Yes, this patch should fix every chromedir= occurence.
Assignee

Comment 6

8 years ago
Pushed to comm-central: <http://hg.mozilla.org/comm-central/rev/8bdd5d2f7ece>
and to comm-aurora: <http://hg.mozilla.org/releases/comm-aurora/rev/f5cf00dfa02f>
and to comm-beta: <http://hg.mozilla.org/releases/comm-beta/rev/00948fc038f1>
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.2
I'm confused because the patch doesn't remove the |chromedir="&locale.dir;"| usage as indicated by comment 4 and comment 5. Are the entries still required in the *.xml and *.xul files or not?
Assignee

Comment 8

8 years ago
I'm not sure but when I check <http://mxr.mozilla.org/comm-central/search?string=chromedir=> then also a lot of toolkit and mailnews files have still chromedir. Because of this I let them and changed only the css files.
(In reply to Richard Marti [:paenglab] from comment #8)
> I'm not sure but when I check
> <http://mxr.mozilla.org/comm-central/search?string=chromedir=> then also a
> lot of toolkit and mailnews files have still chromedir. Because of this I
> let them and changed only the css files.

It does not make sense to have a chromedir attribute on elements if no CSS selector uses it afaik.
You need to log in before you can comment on or make changes to this bug.