renameAttachment.label/accesskey in messengercompose.dtd are defined twice

RESOLVED FIXED

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Alexander L. Slovesnik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 526998])

(Reporter)

Description

6 years ago
With Bug 526998 fixed there are two occurences of renameAttachment.label/accesskey in http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/messengercompose.dtd

In http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/messengercompose.dtd#76 :
<!ENTITY renameAttachment.label "Rename Attachment…">
<!ENTITY renameAttachment.accesskey "e"> 

http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/messengercompose/messengercompose.dtd#267 :
<!ENTITY renameAttachment.label "Rename…">
<!ENTITY renameAttachment.accesskey "R">

I suppose, one of them should be removed or renamed. I don't know which one will be shown in interface.

Comment 1

6 years ago
Alexander, thank you. Both labels are needed for the UI, but we need to rename the first one.

Current labels (after bug 526998), because of this bug:

Edit Menu: Rename Attachment... (renameAttachment.label)
Attachment Context Menu: Rename Attachment... (renameAttachment.label)

Expected labels:

Edit Menu: Rename Attachment... (renameAttachment*Cmd*.label)
Attachment Context Menu: Rename... (renameAttachment.label)

Details/Reasons:

- on the context menu, we don't usually mention the context in the label unless it's needed for disambiguation (which is why we have "Open" and "Select All", but "Remove Attachment", although I don't really see the ambiguity here)
- on the context menu, shorter labels = less clutter, easier to parse visually
--> on context menu, the label text should be just "Rename..."

- on Edit Menu, we need the full context in the label because it's not obvious:
--> "Rename Attachment..."
--> Proposed label name: renameAttachmentCmd.label
- the name should contain "Cmd", like all other labels in this corner (this bug)

Proposed Fix:

Change the "Rename Attachment..." label name for *Edit Menu* to be renameAttachment*Cmd* instead of renameAttachment:

<!ENTITY renameAttachmentCmd.label "Rename Attachment…">
<menuitem id="menu_RenameAttachment" label="&renameAttachmentCmd.label;"

While we are here, we should also add a comment for attachment pane context menu:
 
<!-- Attachment Pane Context Menu -->
<!ENTITY openAttachment.label "Open">
...

Updated

6 years ago
Keywords: regression

Comment 2

6 years ago
Fixed by bug 526998.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: regression
Resolution: --- → FIXED

Updated

6 years ago
Whiteboard: [fixed by bug 526998]
You need to log in before you can comment on or make changes to this bug.