Obtain more telemetry data for app update memory errors

RESOLVED FIXED in mozilla12

Status

()

Toolkit
Application Update
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

unspecified
mozilla12
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Comparing the current UPDATE_STATUS telemetry data week to week, it shows that ~5% of updates fail with error code 1 which is a memory error.  Some weeks it shows as much as 8%, other weeks as low as 3%.

We currently use memory errors a lot throughout the updater code though, so it's hard to tell what the problem is.
We also assume a memory error when the error could be from something else such as in the case of WideCharToMultiByte calls.

This bug is to add different error codes and to adjust the telemetry histogram so we can get a better idea why these errors happen.

A follow up bug will likely be posted once we gather the needed data from this bug.
(Assignee)

Comment 1

7 years ago
Created attachment 588798 [details] [diff] [review]
Patch v1.
Attachment #588798 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

7 years ago
Blocks: 715942
Comment on attachment 588798 [details] [diff] [review]
Patch v1.

Nice!
Attachment #588798 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 3

7 years ago
Pushed to inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/acbca13be1cb
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/acbca13be1cb
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

7 years ago
So relating to this telemetry data:

We are still showing an error of 1 on telemetry.  None of these new codes are being shown.  Possibly people can't update and are stuck on an old version always returning a memory error of 1.

But I'm a bit confused because these users would have had to update originally to the telemetry build that ehsan did for update.status.

Seems like either we're returning an error of 1 on all telemetry updates, or I missed a return code somewhere that is still 1.
(Assignee)

Comment 6

7 years ago
I should note that a couple of time I manually put values in my file for testing and those show up, so I don't know what's going on.
(Assignee)

Comment 7

6 years ago
Bug 731901 explains Comment 5.  This fix is still valid though because it just creates new error codes to help narrow down errors when they happen.
You need to log in before you can comment on or make changes to this bug.