everything in XUL Test Suite results in XML Parsing Errors

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
SeaMonkey has a Debug > XUL Test Suite submenu. In SM 2.7b2 and b3, every item on that menu results in XML parsing errors. Visiting same URLs in Firefox nightly results in the same errors, so I'm filing a core bug.

Steps to reproduce
1. Choose anything from SeaMonkey's Debug > XUL Test Suite menu, or enter a URL like http://www.mozilla.org/projects/xul/tests/stacks.xul

Results:
XML Parsing Error: 
Location: http://www-archive.mozilla.org/projects/xul/tests/stacks.xul
Line Number 28, Column 37:        onload="" orient="vertical">
------------------------------------^

But the document passes XML validation (
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.mozilla.org%2Fprojects%2Fxul%2Ftests%2Fstacks.xul ), so it's something else.

On IRC NeilAway commented "probably remote xul blocking it". If I save the file locally as test.xml I get the same parsing error, but if I change the extension to .xul I get an in-window rounded box error
    Remote XUL
    This page uses an unsupported technology that is no longer available by default.

So maybe there's a bug separate from the test suite that a Remote XUL error is misreported as an XML Parsing Error.  And a wish that the Remote XUL Manager add-on https://addons.mozilla.org/en-US/seamonkey/addon/remote-xul-manager/ be compatible with SeaMonkey 2.7.
XUL elements in a non-XUL remote (and that includes file:// URIs) page are treated as a parse error, last I checked.  I believe that's the expected behavior, but ccing sicking to confirm.
Yup, this is expected behavior since we disabled remote XUL.

If you load XUL using chrome:// urls it should work just fine, but you can probably not load these test pages that way without installing them as an addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

6 years ago
Wow, working 7 days a week, thanks! I filed bug 718356 to remove the submenu in SeaMonkey. The XML Parsing Error is unhelpful and points to a random part of the XUL file, but I'll let it go ;-)
Blocks: 718356
You need to log in before you can comment on or make changes to this bug.