Closed Bug 718386 Opened 8 years ago Closed 8 years ago

Attempting to open an event from message window fails (modifyEventWithDialog is not defined)

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect, major)

Lightning 1.2
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: Fallen)

Details

(Keywords: regression, Whiteboard: [wanted-1.2.2])

Attachments

(1 file)

STR:

1) Have an invite that has already been processed.
2) Open the email, and select "Open" to open the actual event.

Actual Results:

Nothing happens, this is seen on the error console:

Error: modifyEventWithDialog is not defined
Source File: chrome://lightning/content/imip-bar.js
Line: 170

Expected Results:

Open the event.
(Version 1.2b2)
Version: Trunk → Lightning 1.2
Attached patch Fix - v1 β€” β€” Splinter Review
This should take care.
Attachment #588944 - Flags: review?(bv1578)
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Whiteboard: [wanted-1.2.2]
On Win7, I can't reproduce this bug with any 1.2* version of Lightning.
The event dialog appears without any error in the console.

What is the exact version to use (or is there the need of further clarifications in steps to reproduce)?
Decathlon, are you sure you are opening the event dialog from a single message window? i.e str:

1) Have an invite that has already been processed.
2) Doubleclick on a message with invitation to open it in a new window
3) Open the email, and select "Open" to open the actual event.

I'm likely going to take this patch for beta, but as always I'd appreciate a review anyway.
Comment on attachment 588944 [details] [diff] [review]
Fix - v1

I had not understood that the message had to be open in a new window instead of a new tab (the patch had to give me some clue though. Sorry).

r+
Attachment #588944 - Flags: review?(bv1578) → review+
Pushed to comm-central changeset 0413af917a70
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.5
Backported to releases/comm-aurora changeset 47a0cd44ed96
Target Milestone: 1.5 → 1.4
Backported to releases/comm-beta changeset 6637682315e3
Target Milestone: 1.4 → 1.3
Backported to releases/comm-release changeset 9f712fac7eca for Lightning 1.2.2
Target Milestone: 1.3 → 1.2.2
You need to log in before you can comment on or make changes to this bug.