Closed Bug 718393 Opened 9 years ago Closed 8 years ago

Almost impossible to position the caret inside a text field

Categories

(Firefox for Android :: General, defect, P3)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 795045

People

(Reporter: ecfbugzilla, Unassigned)

Details

Attachments

(2 files)

Attached file Testcase
If I mistyped something and have to go back a few characters, positioning the caret correctly seems almost impossible (both Aurora and Nightly). Steps to reproduce:

* Open the attached testcase in Fennec.
* Touch the text field to open the virtual keyboard.
* Position your caret somewhere in the text field.
* Now try to move it forward by one position.

Expected result:

The caret moves forward by one or two positions, depending on how precise your aiming is. Eventually a UI element appears that allows more precise positioning.

Actual result:

The text field turns yellow for every touch but most of the time the caret moves unpredictably. Often it jumps out of the screen (or at least I cannot see it), sometimes it stays at the old position or moves back (!). There is no positioning help so that you are bound to keep experimenting - eventually there will be a hit.
Attaching a screenshot of the built-in browser on Samsung Galaxy S II. No erratic caret movements - the caret either moves into the expected direction (and gets positioned pretty precisely) or doesn't move at all (if the distance is too small, depends on zoom). A positioning help appears that allows more precise positioning (its own positioning is slightly off but it works well nevertheless).
we might be able to simulate something like what android does for content text fields.
tracking-fennec: --- → 12+
Priority: -- → P3
tracking-fennec: 12+ → ?
Keywords: qawanted
This should be fixed now with thumb cursor controls, no? Wladimir, can you verify?
Flags: needinfo?(trev.moz)
I'm not sure whether the current state can be considered as "fixed". Most of the time I try to move the thumb it either disappears (I moved it a bit too far up or down and the text field lost focus), the cursor jumps to the end of the text field (apparently the case if the thumbs points at the lower border of the text field) or even to the beginning of it (if I move the thumb too far up and it touches the upper border of the text field). It seems that I currently have to do the following:

* Move the thumb up a bit so that it points to the middle of the text field.
* Move it horizontally now to position the cursor and be careful not to change its vertical position too much.

This requires quite a bit of coordination which shouldn't be necessary IMHO - once the thumb is touched its vertical position should no longer matter, it should just move horizontally. Plus there should be some tolerance in case the touch doesn't hit the thumb precisely.
Flags: needinfo?(trev.moz) needinfo?(trev.moz) → needinfo-
We know about those issues.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Seems odd to close a bug as WFM if we know about the issues. Is there an existing bug this should be duped to? Or is this behaviour WONTFIX?
Dependencies should be filed off bug 652168. If these specific issues aren't there, we should make sure there are bugs filed so that we can fix them.
The issues I noted seem to be covered by bug 795045.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 795045
Keywords: qawanted
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.