Closed Bug 718400 Opened 11 years ago Closed 11 years ago

Set up pre-approval on Payment Profile does not work after user is logged in

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cboldan.mozbugs, Unassigned)

References

Details

Steps to Reproduce:
1. Login to APPS https://apps-preview-dev.allizom.org/en-US/firefox
2. Click on "{username} -> Payment Profile".
3. Click on "Set up pre-approval" button and complete the form.
4. Click on "Return" button to get back to the Apps website.

Expected Results:
"Pre-approval set up." message is displayed. The "Set up pre-approval" button label is replaced with "Remove pre-approval" and the message "Your pre-approval is set up." is displayed above.

Actual Results:
"Pre-approval set up." message is displayed. "Set up pre-approval" button remains, pre-approval is not set up. User has to go through the whole process again for the pre-approval to work.

Notes/Issues:
Screencast for this issue http://screencast.com/t/yRhAYtSA
Blocks: 710074
https://github.com/mozilla/zamboni/commit/ac04a1
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 714956
Verified as fixed in https://apps-preview-dev.allizom.org/en-US/firefox
Postfix screencast http://screencast.com/t/CM23A3jVpXmo
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.