Closed Bug 718411 Opened 8 years ago Closed 7 years ago

test_playback.html | an unexpected uncaught JS exception reported through window.onerror - Utils is not defined at chrome://global/content/bindings/videocontrols.xml

Categories

(Toolkit :: Video/Audio Controls, defect)

12 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: smaug, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

No description provided.
Bug 718340 may have caused this. investigating.
Attached file test
If I read the XBL code (C++ and videocontrols.xml) correctly, this is a valid
bug. Utils field can be deleted from the js object, yet some timeout function 
tries to use it.
Attached patch patch (obsolete) — Splinter Review
This could hopefully fix the problem.
Attachment #588976 - Flags: review?(jwein)
Comment on attachment 588976 [details] [diff] [review]
patch

Review of attachment 588976 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine to me. I tested this out on my Windows build by causing the timeout to be set and then closing the tab or navigating away from the page. I couldn't reproduce the exception with or without the patch though (but that's probably expected due to its randomness).

I'd grant an r+ but I'm not a toolkit peer, so I've passed this review on to Dolske. Thanks for fixing this!
Attachment #588976 - Flags: review?(jwein)
Attachment #588976 - Flags: review?(dolske)
Attachment #588976 - Flags: feedback+
Comment on attachment 588976 [details] [diff] [review]
patch

Review of attachment 588976 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/widgets/videocontrols.xml
@@ +306,5 @@
>              <![CDATA[
>              this.Utils.init(this);
>              ]]>
>          </constructor>
> +        

Nit: Please remove this extra whitespace.
I was told this happened even without the patch for Bug 718340.
(In reply to Olli Pettay [:smaug] from comment #8)
> I was told this happened even without the patch for Bug 718340.

It might only happen on opt builds, of which I'm running a debug build.
Duplicate of this bug: 718520
Blocks: 438871
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [orange]
No longer blocks: 718520
Comment on attachment 588976 [details] [diff] [review]
patch

Based on tryserver, this doesn't fix the problem :(
Attachment #588976 - Attachment is obsolete: true
Attachment #588976 - Flags: review?(dolske)
Comment 18 was from the merge of the merge from fx-team, a perhaps more likely place for it to start, since it brought over the patch for bug 689387, and in fact there is an unstarred instance of this on the fx-team push of that.
Blocks: 689387
This problem is verified in version 13.  I can reproduce it 100% of the time.  I get 2 exceptions in rapid succession when I navigate away from a playing video:

chrome://global/content/bindings/videocontrols.xml(639): event.item is undefined
chrome://global/content/bindings/videocontrols.xml(816): Utils is not defined
No sign of this for many months.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.