Media query detection isn't well implemented

RESOLVED DUPLICATE of bug 712620

Status

()

RESOLVED DUPLICATE of bug 712620
7 years ago
7 years ago

People

(Reporter: m+bugzilla, Unassigned)

Tracking

({css3})

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I was playing with media queries


Actual results:

My max-width rule didn't work


Expected results:

The max-width media query should work
(Reporter)

Comment 1

7 years ago
Well okay, let's talk about what was happening to me about media queries.

I was trying to simulate a responsive design on a smartphone so I specified a certain css rule, this one: @media screen and (max-width: 320px). It never worked.

In fact, it's because I've too many elements in my firefox interface. Every element has its own min-width, and when you count all these min-width, it takes 355px.

I've removed my previous/next button, my search engine, and my rss button. At this time my css rule worked.


So all min-width media query rules won't never work until your min-width gui is bigger than them.

It should be better if media queries were based on inner window and now outer window. It should be the same for all content in fact.
Keywords: css3
(Reporter)

Comment 2

7 years ago
"It should be better if media queries were based on inner window and *not* outer window."

My bad.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712620
You need to log in before you can comment on or make changes to this bug.