Closed Bug 718474 Opened 11 years ago Closed 9 months ago

Changes to zoom.maxPercent require restart

Categories

(Firefox :: Settings UI, defect, P3)

defect

Tracking

()

VERIFIED FIXED
100 Branch
Tracking Status
firefox100 --- verified

People

(Reporter: acheron, Assigned: Gijs)

References

Details

Attachments

(1 file)

1. Open about:config and increase zoom.maxPercent above your current limit, e.g. from default 300 to 500.
2. Try to zoom any webpage above 300% by pressing Ctrl-+. -- Zooming stops at 300%.
3. Try to zoom any webpage above 300% by holding Ctrl and scrolling a mouse wheel. -- The page is briefly zoomed to above 300%, but is quickly reverted to 300%. 

If you quit Firefox and start it again, the limit is changed correctly.
Component: General → Preferences
QA Contact: general → preferences
Also it works correctly for images.
See Also: → 1658482
Severity: normal → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Version: 9 Branch → Trunk
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/74ef7968d60e
allow changing zoom values, min and max, at runtime, r=morgan
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
Flags: qe-verify+

I was able to reproduce this issue on Firefox 98(20220304153049) on Win10 64-bit using the steps from the Description. The issue is partly resolved(zooming with Ctrl+Mouse Wheel behaves as expected), however, keyboard scrolling is still faulty on Firefox 100.0b7(20220417185951) and Nightly 101.0a1(20220419093010). It will not go above the maximum zoom level before the tweaks in about:config.(In newer version of Firefox the default zoom value is 500; I changed it to 700, restarted the browser and tried to zoom in without success). Also, if one zooms in using Ctrl+Mouse Wheel above a 500 value, and tries to zoom out using the keyboard, the value will downgrade directly to 400.
I'm leaving a recording of the keyboard scroll on Fx 100 here.
On macOS 11 and Ubuntu 20 the same behaviour is enconteured - mouse zooming is working as expected, but keyboard zooming is not.
Should I re-open this bug or fill a new one strictly related to the keybooard zoom issue?
Thank you in advance.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Ardelean Oana from comment #5)

I was able to reproduce this issue on Firefox 98(20220304153049) on Win10 64-bit using the steps from the Description. The issue is partly resolved(zooming with Ctrl+Mouse Wheel behaves as expected), however, keyboard scrolling is still faulty on Firefox 100.0b7(20220417185951) and Nightly 101.0a1(20220419093010). It will not go above the maximum zoom level before the tweaks in about:config.(In newer version of Firefox the default zoom value is 500; I changed it to 700, restarted the browser and tried to zoom in without success). Also, if one zooms in using Ctrl+Mouse Wheel above a 500 value, and tries to zoom out using the keyboard, the value will downgrade directly to 400.
I'm leaving a recording of the keyboard scroll on Fx 100 here.
On macOS 11 and Ubuntu 20 the same behaviour is enconteured - mouse zooming is working as expected, but keyboard zooming is not.
Should I re-open this bug or fill a new one strictly related to the keybooard zoom issue?
Thank you in advance.

You would have to also change toolkit.zoomManager.zoomValues, which is a comma separated list of zoom values (divided by 100, so .3 is 30%, and 5 is 500% - you'd want to add values (like ,6,7) to the end to confirm zooming to 700 or w/e works. Can you re-test with that and confirm it works?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(oardelean)

Thank you for you answer! I can confirm that after changing the toolkit.zoomManager.zoomValues pref - adding 6,7 values - it works as expected with both mouse and keyboard zooming. Re-tested on Firefox 100.0(20220428192727) and Nightly 101.0a1(20220428214715) on macOS 11, Win10 64-bits and Ubuntu 20.04, verified as fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(oardelean)
You need to log in before you can comment on or make changes to this bug.