Sending emails to newsgroups makes me crash [@ nsMsgLocalMailFolder::WriteStartOfNewMessage]

RESOLVED FIXED in Thunderbird 12.0

Status

MailNews Core
Backend
--
critical
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: armenzg, Assigned: Bienvenu)

Tracking

({crash, regression})

Trunk
Thunderbird 12.0
x86
All
crash, regression

Thunderbird Tracking Flags

(thunderbird11 unaffected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The email still gets sent but Daily has to get restarted.

This problem is for Mac and it started on Monday 9th.
I had been off for 2 weeks.

I don't know how to check for my version (how can I load about:?)
(Reporter)

Updated

6 years ago
Summary: Sending emails to newsgroups make me crash → Sending emails to newsgroups makes me crash
(Reporter)

Comment 1

6 years ago
12.0a1 2012-01-16
(Reporter)

Comment 2

6 years ago
Thanks to jcranmer:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20120116 Thunderbird/12.0a1
https://crash-stats.mozilla.com/report/index/bp-e00eccfa-974c-4288-8444-214f42120116
https://crash-stats.mozilla.com/report/index/bp-76981e62-49fe-46dc-b47e-26a092120116
(Reporter)

Comment 4

6 years ago
http://crash-stats.mozilla.com/report/index/bp-b80d2523-2872-42fc-8c96-e45332120110
http://crash-stats.mozilla.com/report/index/bp-6faf84b2-7d90-4d3a-aa7f-0d0b42120110
http://crash-stats.mozilla.com/report/index/bp-0e67f755-9298-4d9a-be75-b705b2120110
http://crash-stats.mozilla.com/report/index/bp-7d649e64-de10-43bc-a3b4-d95c72120110
http://crash-stats.mozilla.com/report/index/bp-ac0a6510-260d-4162-b7c5-6e9a82120110
http://crash-stats.mozilla.com/report/index/bp-216dacf3-e117-48c8-a42c-f2a472111216

Not sure if I had any crash that were not related to this bug.
Crash Signature: [@ nsMsgLocalMailFolder::WriteStartOfNewMessage]
Summary: Sending emails to newsgroups makes me crash → Sending emails to newsgroups makes me crash [@ nsMsgLocalMailFolder::WriteStartOfNewMessage]
Version: unspecified → Trunk
Severity: normal → critical
Keywords: crash
more common signature is nsMsgLocalMailFolder::WriteStartOfNewMessage() per https://crash-stats.mozilla.com/query/query?product=Thunderbird&version=ALL%3AALL&range_value=2&range_unit=weeks&date=01%2F18%2F2012+04%3A00%3A28&query_search=signature&query_type=contains&query=nsMsgLocalMailFolder%3A%3AWriteStartOfNewMessage&reason=&build_id=&process_type=any&hang_type=any&do_query=1

if bp-1ef6ba89-b6c1-4116-86a8-d15fd2111227 is the same crash, then earliest build is ~dec 26. 

(no time for more analysis)
Crash Signature: [@ nsMsgLocalMailFolder::WriteStartOfNewMessage] → [@ nsMsgLocalMailFolder::WriteStartOfNewMessage] [@ nsMsgLocalMailFolder::WriteStartOfNewMessage() ]
Keywords: regression
(Assignee)

Comment 6

6 years ago
what is the fcc folder set to for your news account (account settings, copies and folders)?
(Reporter)

Comment 7

6 years ago
I don't know what fcc means.
Here's a screenshot.
(Reporter)

Comment 8

6 years ago
http://cl.ly/DRQ2

Comment 9

6 years ago
Can't reproduce, but the crash is here:
http://hg.mozilla.org/comm-central/annotate/7bddc0e90669/mailnews/local/src/nsLocalMailFolder.cpp#l1950
as a regression, and top 5 crash for Daily, twould probably be cool to have this fixed before shipping aurora 12.0aN

and not just news - bp-8e90a98e-0655-455e-8c2c-50efb2120122 is via imap
Blocks: 402392
tracking-thunderbird12: --- → ?
Component: General → Backend
OS: Mac OS X → All
Product: Thunderbird → MailNews Core
QA Contact: general → backend
(Assignee)

Comment 11

6 years ago
the db for the sent folder is missing or invalid - patch coming up.
Assignee: nobody → dbienvenu
(Assignee)

Comment 12

6 years ago
Created attachment 591252 [details] [diff] [review]
proposed fix

I verified that with this patch, messages are written to the fcc folder correctly even if the fcc folder .msf file is missing.
Attachment #591252 - Flags: review?(neil)

Updated

6 years ago
Attachment #591252 - Flags: review?(neil) → review+
(Assignee)

Comment 13

6 years ago
http://hg.mozilla.org/comm-central/rev/fd2f08281cf0
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → Thunderbird 12.0
just to be clear - setting tb11 not affected
status-thunderbird11: --- → unaffected
tracking-thunderbird12: ? → ---
You need to log in before you can comment on or make changes to this bug.