IonMonkey: Add support for primitive prototypes in IonBuilder::jsop_getprop.

RESOLVED DUPLICATE of bug 715511

Status

()

RESOLVED DUPLICATE of bug 715511
7 years ago
7 years ago

People

(Reporter: nbp, Assigned: nbp)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
The lack of this feature cause repeated bailouts from sunspider/string-validate-input.js.
(Assignee)

Comment 1

7 years ago
Created attachment 589084 [details] [diff] [review]
Support primitive calls.
Attachment #589084 - Flags: review?(dvander)
(Assignee)

Comment 2

7 years ago
The goal of this patch was to implement the features provided in Bug 715511, such as a follow-up bug can then focus on implementing fast paths for operations such as String.concat, String.charAt or Math.floor which are necessary for benchmarks.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715511
(Assignee)

Updated

7 years ago
Attachment #589084 - Flags: review?(dvander)
You need to log in before you can comment on or make changes to this bug.